Announcement

Collapse
No announcement yet.

NLB Unicast Terminal Server is not working after one of the node is turned off ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NLB Unicast Terminal Server is not working after one of the node is turned off ?

    Hi People,

    Iím having a connectivity issue with my current Terminal Server VM nodes connectivity on Windows 2003 Enterprise SP2, which has been successfully converged and deployed as Unicast NLB with the following configuration:

    Hostname: TS1
    IP: 10.1.1.150
    IP2 NLB Enabled: 10.1.2.95
    Host Priority: 1

    Hostname: TS2
    IP: 10.1.1.242
    IP2 NLB Enabled: 10.1.2.96
    Host Priority: 2

    And I have already created the
    Virtual Cluster name: TerminalServer.domain.com
    Virtual Cluster IP address: 10.1.2.97

    When both servers are ON, user will be randomly allocated to either TS1 or TS2

    When the TS1 server is turned OFF
    ping to TS1 is dropped obviously
    ping to Virtual Cluster IP address is still OK
    remote desktop is failed to connect / redirect to TS2 which it should have.

    When the TS2 server is turned OFF
    ping to TS2 is dropped obviously
    ping to Virtual Cluster IP address is still OK
    remote desktop is failed to connect / redirect to TS1 which it should have.

    Previously it has worked before until one of the node was in error state (WBEM error 0x80041002) in rejoining the NLB cluster.

    Any kind of help and assistance would be greatly appreciated.

    Thanks

  • #2
    Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

    Moved to a perfectly good Terminal Services forum.

    Comment


    • #3
      Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

      Thanks Wullie, hopefully someone here can help me diagnosing this issue.

      Cheers.

      Comment


      • #4
        Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

        Try removing both servers from the cluster and then recreate the cluster.

        Comment


        • #5
          Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

          Hi,

          Please provide us the following information:

          a. Network Switch configurations + vendor + model
          b. What is the host type that used to host the VMs?
          c. Is all the VMs run on the same host?
          Best Regards,

          Yuval Sinay

          LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

          Comment


          • #6
            Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

            Originally posted by joeqwerty View Post
            Try removing both servers from the cluster and then recreate the cluster.
            yes already, that is what happening after I rejoin the NLB cluster.

            Comment


            • #7
              Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

              Originally posted by yuval14 View Post
              Hi,

              Please provide us the following information:

              a. Network Switch configurations + vendor + model
              b. What is the host type that used to host the VMs?
              c. Is all the VMs run on the same host?
              A. CISCO switch... (forgot the model).
              B. VMware ESX 4.1
              C. No they are different.

              Comment


              • #8
                Re: NLB Unicast Terminal Server is not working after one of the node is turned off ?

                Please review:

                http://kb.vmware.com/selfservice/mic...rnalId=1006580

                Also, I recommanded to use hardware load balance and not NLB.
                Best Regards,

                Yuval Sinay

                LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

                Comment

                Working...
                X