Announcement

Collapse
No announcement yet.

Need advices on TS2003 server with high CPU usage by applications

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need advices on TS2003 server with high CPU usage by applications

    Hello to all,

    I installed a TS 2003 server from scratch to replace a unstable TS 2003 server in a Hyper-V environment. Both servers host identical applications and operating system and are both on the same Hyper-V host.

    With the new server I encounter some issue and in one word: slow server. If I look at the CPU usage, applications can take up to 40% of the CPU, sometimes more and only for one user. Every body complains about the slowness, even me

    On the old server, no applications took more than 25% of the CPU usage.

    I didn't find anything that could explain this issue -- application that user more than 25% of the CPU in a TS environment --, and no specific applications were installed on the old server to manage the CPU resources.

    I had to say that I made a mistake while installing the new server -- newbie mistake --:
    * I install it first with Windows 2003 standard and 1 processor.
    * after the end of the first day, I upgrade to 4 processors. But the high CPU usage was still there.
    * I realize that I have installed the standard version instead of the Enterprise version. So I upgrade the TS 2003 from STD to ENT.
    * the CPU usage is still unlimited for users.

    Did my un-managed CPU usage server come from the fact that I made a mistake at the first installation, so using W2003 STD instead of W2003 ENT ?

    If anybody here have an answer, than you in advance for the answer.

    Have a nice day,

    Terry

  • #2
    Re: Need advices on TS2003 server with high CPU usage by applications

    Did the old server was use X64 edition?

    http://technet.microsoft.com/en-us/l...(v=ws.10).aspx

    Second, did you contact the software support and asked them why the application use high CPU rate?

    bdw.. Disable the antivirus on the guest for start.
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Need advices on TS2003 server with high CPU usage by applications

      Yuval,

      Thank you for your answer.

      I am under 32bits operating system and both the old and the new server using the same antivirus.

      As a work around, I have installed threadmaster that help a little bit but I didn't like that kind of solution.
      I tried Windows ressource manager but wasn't able to configure it propertly

      It seems that the system is working with one processor even if 4 are installed. In the performance tab under task manager, all the CPU graphs are with the same curve ... as it is one processor on 4 graphs.

      The only thing I see -- and it seems too crazy to be true -- is that installing a server with one processor and upgrade it to 4 is different than install a server with already 4 processors installed. Am I wrong ?

      Bye

      Comment


      • #4
        Re: Need advices on TS2003 server with high CPU usage by applications

        Hi,

        Did you upgrade the HAL to support multi CPU?

        http://support.microsoft.com/?kbid=309283

        Please note: To use multi CPU server, the software code should support this type of work.
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment


        • #5
          Re: Need advices on TS2003 server with high CPU usage by applications

          Hello,

          Just a small feed back.

          As I said, I've installed ThreadMaster to limit the CPU process used on SERVER-ONE.

          This morning, I installed a new W2003 ENT 32bits from scratch (SERVER-TWO), already with 4 CPU and 4 GB of RAM. I configued it as a Terminal Server with Office 2007 and a proprietary application -- not really 32 bits as some functions launch the wowexec --.

          With this new SERVER-TWO, none of the application will go over 25% of CPU. For the test I lauched the proprietary application and started a PDF-to-Excel export of 500 pages of data.

          I tested the same export on SERVER-ONE and there, without ThreadMaster in action, the CPU process used by Excel reach 30% to 40% of the server.

          A question came into my mind: if we install a virtual server with one processor and then upgrade it to 4 processors once the systeme updated and configured (and yes with the HAL support to multi-CPU enabled) , why does this server didn't act as a virtual server installed with 4 processors at first configuration ?

          Comment


          • #6
            Re: Need advices on TS2003 server with high CPU usage by applications

            Hi,
            You may need to remove and install the integration tools from the system.
            Best Regards,

            Yuval Sinay

            LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

            Comment

            Working...
            X