Announcement

Collapse
No announcement yet.

3389 isn't listening - Serveral RDP drivers won't start after reboot?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3389 isn't listening - Serveral RDP drivers won't start after reboot?

    I'm running 2008 R2 standard. I do not have the Remote Desktop Services Role installed. RDP is enabled through the system properties by checking "Allow connections from computers running any version of Remote Desktop" and the appropriate users are selected for RDP access. RDP was working on this server, and it stopped suddenly, not sure why.

    I have noticed that after a reboot, in the device manager, the following drivers are stopped:

    Remote Desktop Services Security Filter Driver
    RDP Winstation Driver

    Even after starting them, and then restarting all of the RDP like services, the server is still not listening on port 3389 (and no, the default RDP listen port has not been modified).

    Does anyone have any info that might lead me in the right direction as to why port 3389 isn't listening?
    Thanks

  • #2
    Re: 3389 isn't listening - Serveral RDP drivers won't start after reboot?

    Hi,

    If you enable this services in the device manager and reboot, the RDP isnt function?
    Did you tried to uncheck: Allow connections from computers running any version of Remote Desktop" , reboot and re-check Allow connections from computers running any version of Remote Desktop" ?

    Also, do you have some antivirus/DLP software on the server?
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: 3389 isn't listening - Serveral RDP drivers won't start after reboot?

      Originally posted by yuval14 View Post
      Hi,

      If you enable this services in the device manager and reboot, the RDP isnt function?
      Did you tried to uncheck: Allow connections from computers running any version of Remote Desktop" , reboot and re-check Allow connections from computers running any version of Remote Desktop" ?

      Also, do you have some antivirus/DLP software on the server?
      Correct, starting the drivers and restarting the services and then restarting the entire server doesn't fix it. And yes, I've tried unchecking and rechecking allow remote connections. There is no a/v or anything like that on this system and windows firewall is disabled.

      Comment


      • #4
        Re: 3389 isn't listening - Serveral RDP drivers won't start after reboot?

        Hi,

        1. Please update the server to the latest hofix/service pack.

        2. Then, please review "remote desktop session host configuration" -> security layer settings. What is the current settings?
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment


        • #5
          Re: 3389 isn't listening - Serveral RDP drivers won't start after reboot?

          Also, worth double checking that the server has not dropped into a Public or Private FireWall Profile. It should be Domain Profile and possibly you have this turned off. If so, the below is an update worth applying as well as the recommended ones of Yuval.

          http://support.microsoft.com/kb/2524478
          Last edited by Virtual; 29th May 2012, 16:00.

          Comment

          Working...
          X