Announcement

Collapse
No announcement yet.

Cannot access published .local VM from RD Web with a .com address

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot access published .local VM from RD Web with a .com address

    Hi
    I would really appreciate some help getting access to my published RD Web VM from an external location.

    My setup so far:
    svr.ourdomain.local running RDS roles and IIS TSGateway set to svr.ourdomain.com which has a public A record pointed at.

    We can access the RD Web page both internally and externally and sign in, using svr.ourdomain.com/rdweb

    We have a published VM that resides on our Hyper V server in the local domain, which we can access via RD Web internally, using svr.ourdomain.com/rdweb

    But, if we try and access externally we get a "Can't find the computer" error

    The RD Connection broker Server is set to svr.ourdomain.local

    The TSGateway is set to svr.ourdomain.com/rdweb

    I expect that this is caused by the external client not being able to resolve the internal connection broker server address.

    Can anyone help us work round?

    Thanks

  • #2
    Re: Cannot access published .local VM from RD Web with a .com address

    Hi,
    Please use nlookup and set via host file etc. the correct settings...
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Cannot access published .local VM from RD Web with a .com address

      Thanks Yuval

      Sorry for being completely ignorant.

      Do you mean add a lookup in the host file on the client machine?

      Or do we need to add a DNS record on our AD DNS server? Not sure how to do this as any record added will have the domain .local suffix

      Step by step help would really be appreciated.

      Comment


      • #4
        Re: Cannot access published .local VM from RD Web with a .com address

        Nslookup allow you to query the DNS server. For example,
        TS Broker -

        please do nslookup to the following names:
        1. It self.
        2. Remote Desktop servers.
        3. Remote Desktop gateway.
        4. Remote Desktop Web server.

        you should find that each server was answered correctlly. If this isnt the case, try to ping to the each server IP and then add the following settings to the host file:

        192.168.0.1 servername servername.localdomainname.local
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment

        Working...
        X