Announcement

Collapse
No announcement yet.

Because of an error in data encryption, this session will end. Please try connecting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Because of an error in data encryption, this session will end. Please try connecting

    If I try to RDP to a 2008 server on the 30.0 network from ANY (XP, VISTA, 7) client on the 20.0 network, my rdp session terminates with an error (Because of an error in data encryption, this session will end. Please try connecting to the remote computer again), however if I try to RDP from the same client on the 20.0 network to a 2003 server running on the same ESXi, the problem does not exist.
    Also if I poke a hole (TCP 3389) in RV042 and make 2008 server accessible over RDP from outside, I don’t have any problems connecting to the 2008 server even from the laptop that was getting disconnected over hardware VPN.
    Any thoughts?

    P.S Transferring large files in any direction (over 300Mb) is NOT a problem from any computer on the 20.0 network to a 2008 server on the 30.0 network . (using windows shares \\Server2008\Public )

    Last edited by net_tech; 28th October 2010, 16:22.

  • #2
    Re: Because of an error in data encryption, this session will end. Please try connec

    Looks like I need 3 more posts to insert a link to a diagram

    Comment


    • #3
      Re: Because of an error in data encryption, this session will end. Please try connec

      Something else to add...

      I have seen a post on another forum where people disabled LSO on the nic and it fixed their problem, but in my case it didn't do anything to RDP, but broke Exchange 2007
      Last edited by net_tech; 28th October 2010, 16:51.

      Comment


      • #4
        Re: Because of an error in data encryption, this session will end. Please try connec

        just saw this

        http://www.petri.com/network-issues-...ll-servers.htm

        but if i disable LSO on my 2008 server and reboot the server, Exchange 2007 services fail to start ( hang starting )
        Last edited by net_tech; 28th October 2010, 16:51.

        Comment


        • #5
          Re: Because of an error in data encryption, this session will end. Please try connec

          One thing you could try if you have access to the Microsoft connect website is the Remote Desktop Connection Manager V2.2 Although it's still in testing I've found it incredibly useful as it seems to iron out a few of the ripples you may encounter with the standard mstsc rdp's.

          The other thing to consider is packet loss on the vpn is it a private or open circuit vpn?

          Comment


          • #6
            Re: Because of an error in data encryption, this session will end. Please try connec

            even if Remote Desktop Connection Manager V2.2 works, this would not be a solution to the problem. I am not looking for a work-around, I am looking for a permanent fix.

            This is a private VPN and packet loss is somewhere around 2% - 3%, which is very acceptable for a WAN connection.

            I got a suggestion from a VMWare group to change vmnic0 from 1000 / Full Duplex to Auto (which it should have been) in ESXi , but default setting is 1000 / Full and nobody knows why VMWare chose to have uncommon default settings.

            Will post test results at the end of the day...
            Last edited by net_tech; 29th October 2010, 19:30.

            Comment


            • #7
              Re: Because of an error in data encryption, this session will end. Please try connec

              Hi,

              1. ESXi isnt supported so I can recommanded you to buy ESX license.

              2. What type of virtual NIV driver you have on the VM?

              3. Did you upgrade to the latest ESXi + VMware Tools? If the answer is no, then do it first please.

              4. Please upgrade the RDP client to RDC 7.1.

              5. Is the terminal server license work OK and you are using the correct license model?

              6. Go to the TS: Local Area Connection -> Properties -> Configure -> Advanced -> IPv4 Large Send Offload = Disabled

              * I recommanded to move to Win 2008 R2.

              7. Please review:

              http://support.microsoft.com/?kbid=323497

              * Backup the registry first and then cosider to change the settings. Acording to the KB, its didnt wrote to Win 2008.

              8. MTU issue - This can be change on the firewall side (for example).
              Best Regards,

              Yuval Sinay

              LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

              Comment


              • #8
                Re: Because of an error in data encryption, this session will end. Please try connec

                Originally posted by yuval14 View Post
                Hi,

                1. ESXi isnt supported so I can recommanded you to buy ESX license.

                2. What type of virtual NIV driver you have on the VM?

                3. Did you upgrade to the latest ESXi + VMware Tools? If the answer is no, then do it first please.

                4. Please upgrade the RDP client to RDC 7.1.

                5. Is the terminal server license work OK and you are using the correct license model?

                6. Go to the TS: Local Area Connection -> Properties -> Configure -> Advanced -> IPv4 Large Send Offload = Disabled

                * I recommanded to move to Win 2008 R2.

                7. Please review:

                http://support.microsoft.com/?kbid=323497

                * Backup the registry first and then cosider to change the settings. Acording to the KB, its didnt wrote to Win 2008.

                8. MTU issue - This can be change on the firewall side (for example).

                1. ESXi isn’t supported by whom?

                2. Using e1000 driver, and it's 8.3.2.8 version of Intel(R) PRO/1000 MT Network driver.

                3. ESXi was a brand new install, never upgraded. It's
                VMWare ESXi 4.1.0 Build 260247 VMWare tools are installed
                8.3.2 build 257589

                4. That's what I am using (TS Client is not a problem)

                5. I am just using Remote Desktop Connection (TS Role is not installed)

                6. As I said im my 3rd post, it breakes Exchange 2007 services.
                Why R2? Why not Linux?

                7. 323497 Does not apply to 2008.

                Comment

                Working...
                X