Announcement

Collapse
No announcement yet.

RD Connection Broker will not install

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RD Connection Broker will not install

    Hi folks,

    This one is really doing my head in. I've got this setup on other servers without issue.:

    Server 2012 R2, brand new install.
    Already running Hyper-V, DC, DNS, DHCP with Exchange in a VM.

    The server is replacing an SBS server so I'm setting up an RD Gateway for people to connect to their PCs.

    The server boots normally. No pending updates, no failures or attempts to do anything.

    If I attempt to install the RD Connection Broker role, it goes through the motions and then fails part way through saying "Installation of one or more roles, role services, or features failed. Error: 0x800f0922".

    rom that point on, Server Manager dies and can no longer connect to manage any role. The RD Gateway Role is already installed but none of the other roles are wanted on this server.

    When I reboot the server goes through the motions of applying an update, stays at 51% for a while then quickly fails, reverts and finishes booting.

    CBS.log gives me this as the final error before the rollback.

    2015-07-13 19:52:42, Info CSI 0000008a Creating NT transaction (seq 5), objectname [6]"(null)"
    2015-07-13 19:52:42, Info CSI 0000008b Created NT transaction (seq 5) result 0x00000000, handle @0x720
    2015-07-13 19:52:43, Info CSI 0000008c Error STATUS_CANNOT_DELETE while executing operation DeleteFile on [l:74{37}]"\??\C:\Windows\system32\TSCPUBSvr.dll"
    A bit further back shows what seems to be the main error. TssdisAI install is failing to look up an account, group or similar but it doesn't say what. I can find very little on TssdisAI at all so I'm a bit stumped.

    2015-07-13 19:48:57, Info CSI 00000003 tssdisai.cpp(1183): TssdisAI install...
    2015-07-13 19:48:57, Info CSI 00000004 tssdisai.cpp(931):Entering Windows::WCP::TssDisAI::InstallTSSDIS.
    2015-07-13 19:48:57, Info CSI 00000005 sbconfig.cpp(150):Entering DISSetupSDComputerGroup: 1
    2015-07-13 19:48:57, Info CSI 00000006 sbconfig.cpp(59):Entering GetWellKnownGroupAndDomainName
    2015-07-13 19:48:57, Info CSI 00000007 sbconfig.cpp(84):LookupAccountSid failed with error code 0x80070534.
    2015-07-13 19:48:57, Info CSI 00000008 sbconfig.cpp(136):Leaving GetWellKnownGroupAndDomainName with code 0x80070534.
    2015-07-13 19:48:57, Info CSI 00000009 sbconfig.cpp(165):Failed in GetWellKnownGroupAndDomainName: 0x80070534
    2015-07-13 19:48:57, Info CSI 0000000a sbconfig.cpp(174):Leaving CSbConfig:ISSetupSDComputerGroup : DWORD : 0x80070534
    2015-07-13 19:48:57, Info CSI 0000000b sbconfig.cpp(25):Entering DISSetupAdjustDCOMSecurity.
    2015-07-13 19:48:57, Info CSI 0000000c sbconfig.cpp(39):Leaving CSbConfig:ISSetupAdjustDCOMSecurity : DWORD : 0x0
    2015-07-13 19:48:57, Info CSI 0000000d sbconfig.cpp(150):Entering DISSetupSDComputerGroup: 1
    2015-07-13 19:48:57, Info CSI 0000000e sbconfig.cpp(59):Entering GetWellKnownGroupAndDomainName
    2015-07-13 19:48:57, Info CSI 0000000f sbconfig.cpp(84):LookupAccountSid failed with error code 0x80070534.
    2015-07-13 19:48:57, Info CSI 00000010 sbconfig.cpp(136):Leaving GetWellKnownGroupAndDomainName with code 0x80070534.
    2015-07-13 19:48:57, Info CSI 00000011 sbconfig.cpp(165):Failed in GetWellKnownGroupAndDomainName: 0x80070534
    2015-07-13 19:48:57, Info CSI 00000012 sbconfig.cpp(174):Leaving CSbConfig:ISSetupSDComputerGroup : DWORD : 0x80070534
    2015-07-13 19:48:57, Info CSI 00000013 tssdisai.cpp(387):Entering Windows::WCP::TssDisAI::InstallBrokerDatabase.
    2015-07-13 19:48:57, Info CSI 00000014 sbconfig.cpp(59):Entering GetWellKnownGroupAndDomainName
    2015-07-13 19:48:57, Info CSI 00000015 sbconfig.cpp(84):LookupAccountSid failed with error code 0x80070534.
    2015-07-13 19:48:57, Info CSI 00000016 sbconfig.cpp(136):Leaving GetWellKnownGroupAndDomainName with code 0x80070534.
    2015-07-13 19:48:57, Info CSI 00000017 tssdisai.cpp(39:GetWellKnownGroupName returns error : 0x80070534
    2015-07-13 19:48:57, Info CSI 00000018 tssdisai.cpp(511):Leaving Windows::WCP::TssDisAI::InstallBrokerDatabase.
    2015-07-13 19:48:57, Error CSI 00000019 (F) tssdisai.cpp(966):Failed to install the broker database, error: 0x80070534
    [gle=0x80004005]
    2015-07-13 19:48:57, Info CSI 0000001a tssdisai.cpp(1025):Leaving Windows::WCP::TssDisAI::InstallTSSDIS.
    2015-07-13 19:48:57, Info CSI 0000001b tssdisai.cpp(1142):InstallTSSDIS failed with error code 0x80070534.
    2015-07-13 19:48:57, Info CSI 0000001c tssdisai.cpp(1227):Installer thread failed. Error Code: 0x80070534
    2015-07-13 19:48:57, Info CSI 0000005d Performing 1 operations; 1 are not lock/unlock and follow:
    (0) LockComponentPath (10): flags: 0 comp: {l:16 b:74f4f7929cbdd0016c000000ec1b140d} pathid: {l:16 b:831bf8929cbdd0016d000000ec1b140d} path: [l:234{117}]"\SystemRoot\WinSxS\x86_microsoft.windows.s..ation .badcomponents_31bf3856ad364e35_6.3.9600.16384_non e_cd3183f2deb856d2" pid: 1bec starttime: 130812869080163006 (0x01d0bd9c8192a2be)
    2015-07-13 19:48:57, Error [0x018056] CSI 0000005e (F) Failed execution of queue item Installer: CSI TSSDIS AI installer ({ed201017-97bc-4623-b697-455aaf3654e8}) with HRESULT HRESULT_FROM_WIN32(1332). Failure will not be ignored: A rollback will be initiated after all the operations in the installer queue are completed; installer is reliable (2)[gle=0x80004005]
    The best I can tell, this somehow links to the Windows Internal Database. The only suggest I've found that looks relevant says to try changing that service log on to a domain account account. That made no difference.

    After the failed install, the WID service is dead giving the service did not start due to a logon failure - it seems the Log On As Service right has been revoked from the user account it is running under. Adding that back in allows the service to start again.

    That's about as far as I can get, any suggestions?
Working...
X