No announcement yet.

RemoteApp's only showing for administrator

  • Filter
  • Time
  • Show
Clear All
new posts

  • RemoteApp's only showing for administrator


    I have a problem with the RemoteApp's. Right now if i log in to the webpage in my case: https:\\rdserver\rdweb and login as domain administrator I see the RemoteApp's. If I log in as a normal user it doesn't show the icon.

    First all my details:
    The RDS server is Windows Server 2008 R2 Standard.
    The server is a member server in a 2003 AD domain
    We have 5 CAL's licensed
    I want to give the group f.e. Warehouse to logon to https:\\rdserver\rdweb because we are going to use tablet pc's and handhelds there with a wireless connection. For the handhelds I want them to connect to rdweb to start the application they need.

    My inputs so far:
    -The RemoteApp is added and enabled to show in web access
    -In the properties of the application on the tab User Assignment I added the group Warehouse
    -I have added the computers that are accessing the rdweb in the group TS Web Access Computers
    -I have added the group Warehouse to the group Remote Desktop Users
    -I gave the group Warehouse right to read and execute the webpage of rdserver and rdweb
    -I have added the group Warehouse to the group IIS_USRS
    -I have set the Remote Desktop Services Default Configuration to 'One or more RemoteApp sources' and added the name of the server in this case rdserver.
    -I have added the rights in Windows Powershell for the group Warehouse
    Directory: RDS:\RemoteApp\RemoteAppPrograms\Mfgsys\UserAssign ment
    Name Type CurrentValue GP PermissibleValues PermissibleOperations
    ---- ---- ------------ -- ----------------- ---------------------
    [email protected] String - Get-Item, Remove-Item
    Eventviewer audit failure:
    An account failed to log on.
    Security ID: IIS APPPOOL\RDWebAccess
    Account Name: RDWebAccess
    Account Domain: IIS APPPOOL
    Logon ID: 0x5df82750
    Logon Type: 3
    Account For Which Logon Failed:
    Security ID: NULL SID
    Account Name:
    Account Domain:
    Failure Information:
    Failure Reason: An Error occured during Logon.
    Status: 0x8009030e
    Sub Status: 0x0
    Process Information:
    Caller Process ID: 0x4d8
    Caller Process Name: C:\Windows\System32\inetsrv\w3wp.exe
    Network Information:
    Workstation Name: RDSERVER
    Source Network Address: -
    Source Port: -

    Detailed Authentication Information:
    Logon Process: Authz
    Authentication Package: Kerberos
    Transited Services: -
    Package Name (NTLM only): -
    Key Length: 0
    The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).
    The Process Information fields indicate which account and process on the system requested the logon.
    The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.
    The authentication information fields provide detailed information about this specific logon request.
    - Transited services indicate which intermediate services have participated in this logon request.
    - Package name indicates which sub-protocol was used among the NTLM protocols.
    - Key length indicates the length of the generated session key. This will be 0 if no session key was requested.
    Eventid: 4625

    This all didn't gave me the desired result.
    The result so far is that I only see the programs when I log in as administrator and not as an user who is the group Warehouse.
    Still have to look up the event of the eventvwr, but if someone allready knows an answer the event or to what I want to do please don't hesitate to answer.

    Thanks in advance,


  • #2
    Re: RemoteApp's only showing for administrator

    Please use the following guides:
    Last edited by yuval14; 25th June 2010, 12:51.
    Best Regards,

    Yuval Sinay

    LinkedIn:, Blog:


    • #3
      Re: RemoteApp's only showing for administrator

      Thanks yuval14 for your answer but it didn't guide me to the fix.

      I did follow them, but I finally found my answer in the AD.
      The computer that is actually performing the check of the userís credentials against the RemoteApp programís ACL must be either a member of the domainís Windows Authorization Access Group, or be joined to a domain running in Windows 2000 compatibility mode.

      I added the server to the 2003 AD Windows Authorization Access Group and tried the rdweb again. It worked!!!!!
      In the eventvwr it gave an audit success!

      Finally...Hopefully other users can use this fix also, cause it gave me a lot of irritations.


      • #4
        Re: RemoteApp's only showing for administrator

        Thanks for posting back
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd

        ** Remember to give credit where credit is due and leave reputation points where appropriate **