No announcement yet.

Remote Desktop won't Open...

  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote Desktop won't Open...

    This is very frustrating....I am working on a XP Pro PC with SP3, and I can't get Remote Desktop to open up. I get an hour glass for 1 second, and then is disappears.

    There are no errors in the event log or nothing, the correct Services are running - frustrating.......

    Any ideas?

  • #2
    Re: Remote Desktop won't Open...

    so you try to run remote desktop on your Windows XP SP3 computer, and the application doesn't start, and doesn't give you the window asking for the computer name to connect to, is that correct ?

    Are you on a domain computer, or a standalone ?

    How are you starting remote desktop, via the start menu ? (Start > Acces > Remote Desktop Connection)

    try start > run > mstsc and see if that helps at all ?
    Please do show your appreciation to those who assist you by leaving Rep Point


    • #3
      Re: Remote Desktop won't Open...


      I've tried launching off of the desktop then thru Start>Programs. Also copied a new mstsc to the PC and still nothing.


      • #4
        Re: Remote Desktop won't Open...

        Try launching MSTSC from a command prompt and see if any errors are returned.

        Did you try to register the DLL file?

        regsvr32 mstscax.dll
        You may want to read this thread which explains how to remove the mstsc files, replace them and re-register them. The symptoms in that thread are seemingly identical to yours.
        Wesley David
        LinkedIn | Careers 2.0
        Microsoft Certifications: MCSE 2003 | MCSA:Messaging 2003 | MCITP:EA, SA, EST | MCTS: a'plenty | MCDST
        Vendor Neutral Certifications: CWNA
        Blog: || Twitter: @Nonapeptide || GTalk, Reader and Google+: [email protected] || Skype: Wesley.Nonapeptide
        Goofy kitten avatar photo from Troy Snow:


        • #5
          Re: Remote Desktop won't Open...

          Registered it and ran it from a command prompt. No errors and it still doesn't open - event log show no errors either.


          • #6
            Re: Remote Desktop won't Open...

            Unlikely but worth checking... do you have any security scanners running which could be preventing the application from opening? I do remember a particularly virulent AV identifying a VNC viewer app as a threat and killing it off.

            Has the machine always been standalone, or was it once joined to a domain?
            Gareth Howells

            BSc (Hons), MBCS, MCP, MCDST, ICCE

            Any advice is given in good faith and without warranty.

            Please give reputation points if somebody has helped you.

            "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

            "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.


            • #7
              Re: Remote Desktop won't Open...

              Nope - using SAV 10.1. Won't even launch in Safe Mode.


              • #8
                Re: Remote Desktop won't Open...

                Is this XP SP3 only? It may be a problem with RDP v 5.1

                maybe you could try downloading and installing RDP 6.1 from
                worth a shot.

                also found this where a similar problem happened and SP3 did not update all the files needed:

                Last edited by 1badco3; 24th September 2009, 12:40.


                • #9
                  Re: Remote Desktop won't Open...

                  Did this issue ever get resolved. I am having the same issue, one of our users got infected with the AntiVirus 360, we were able to remove and now the RDP does not launch at all. I've tried the suggestions above but still a no go.

                  Just wanted to see if there were any other thoughts or even better a solution.



                  • #10
                    Re: Remote Desktop won't Open...

                    Please try to upgrade to: RDC 7.0:

                    Best Regards,

                    Yuval Sinay

                    LinkedIn:, Blog:


                    • #11
                      Re: Remote Desktop won't Open...

                      Originally posted by yuval14 View Post
                      Please try to upgrade to: RDC 7.0:


                      This didn't fix the machine I'm working on. The Remote Desktop Client hasn't worked since I cleaned an infection off of it using the scanner. I've tried every suggestion I've found and nothing has fixed it.