Announcement

Collapse
No announcement yet.

NLB issues in 2003 TS Cluster

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NLB issues in 2003 TS Cluster

    Hi

    We've recently built an NLB cluster for terminal servers. We were waiting on a static arp entry to be completed before we could do further testing.

    Now, the NLB doesn't seem to be working exactly right.

    The cluster is configured as:

    tsfarm
    x.x.x.150/20

    There are two nodes configured as:

    tsnd01
    x.x.x.151/20
    priority 5

    tsnd02
    x.x.x.152/20
    priority 2


    When I RDP to the cluster (150), it connects me to tsnd01 even though it has the higher priority.

    If I open NLB manaer from the desktop or the server I get the following message:

    NLB manager is connected to the host using the current dedicated ip address. Therefore the dedicated ip address can not be changed from its current value.

    Note, this is only if I right click tsnd01, and then try to go to another tab. I can freely open the properties on tsnd02 and swap between tabs with no problems. All ip settings are correct, there is nothing in eventviewer on my local machine or the two ts nodes.

    Anyone have any experience with this?

    Thanks

  • #2
    Re: NLB issues in 2003 TS Cluster

    A static arp entry isn't needed unless you configure multicast NLB.
    how have you configured NLB?
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: NLB issues in 2003 TS Cluster

      Originally posted by Dumber View Post
      A static arp entry isn't needed unless you configure multicast NLB.
      how have you configured NLB?
      Sorry, it is configured as multicast.

      Thanks.

      Comment


      • #4
        Re: NLB issues in 2003 TS Cluster

        For multicast, please use only 1 Nic per server.
        In some switches, you may need also to enable IGMP + PIM support.
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment

        Working...
        X