Announcement

Collapse
No announcement yet.

Citrix XenApp 4.5 Web Interface through static nat on firewall

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Citrix XenApp 4.5 Web Interface through static nat on firewall

    I am standing up a new 4.5 Enterprise farm and have everything working ok with the ica connections. Everyone can log in and get a desktop.

    I have published the desktop as an application and am trying to get that to work.

    I can reach the website with no problem and can see the published apps. I have set the altaddr ip address on the server to the external IP

    If I set the secure client access to "translated" and put in the internal and external IP addresses (on port 80) it gets to "Connection in progress.." and hangs and I get no presentation server at that address

    If I set the secure client access to "direct", it gets to "Connection in progress.." and hangs and I get no presentation server at that address

    If I set the secure client access to "Alternate", I double click on the app and nothing happens. In the message center, it says "The resource you requested is no longer available from the servers or the specified user no longer has access to it. No Citrix popup or anything. If I click on it rapidly 15 or 20 times it will sometimes pop up the Citrix connection window and WORK! It will work sporadically if click on the app multiple times.
    Last edited by tnshurtm; 18th February 2009, 16:24.
    Thank you,

    Marc

  • #2
    Re: Citrix XenApp 4.5 Web Interface through static nat on firewall

    also noticed, while in "alternate" mode, the Citrix server logs the "alternate address cannot be found" I have tried using port 80 (that is what I started with) and changing it to port 8080 as well.
    Thank you,

    Marc

    Comment


    • #3
      Re: Citrix XenApp 4.5 Web Interface through static nat on firewall

      ERRRRR!!!!!

      What was causing all of this was that I was load balancing the apps across three servers and have not yet assigned external (altaddr) ips to two of the other servers. If I just have the app on the one server w/ altaddr assigned, it works flawlessly.

      Problem solved.
      Thank you,

      Marc

      Comment


      • #4
        Re: Citrix XenApp 4.5 Web Interface through static nat on firewall

        Please use the following guide:

        http://support.microsoft.com/default.aspx/kb/837739

        btw.. why not to use Citrix gateway appliance/software?
        Best Regards,

        Yuval Sinay

        LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

        Comment

        Working...
        X