Announcement

Collapse
No announcement yet.

Windows 2008 Terminal Services login requiring domain prefix. Any way to change?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 2008 Terminal Services login requiring domain prefix. Any way to change?

    When using the Remote Web Access our users get a login prompt to log into the local workstation rather than the domain, requiring them to enter their username with fully qualified domain credentials. Wondering if there is a setting to log them in with domain credentials by default.

  • #2
    Re: Windows 2008 Terminal Services login requiring domain prefix. Any way to change?

    Please review:

    http://www.msterminalservices.org/ar...ess-Part2.html

    http://www.scribd.com/doc/5987884/Wi...ep-Setup-Guide
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment


    • #3
      Re: Windows 2008 Terminal Services login requiring domain prefix. Any way to change?

      This isn't a gateway server. Just using RemoteApp Web Access without it for now as I don't have a signed SSL certificate.

      characteristics: when establishing a TS RemoteApp Web Access connection the security warning for an unsigned RDP session prompts, hit Connect to accept, next a login prompt asks for domain credentials----- shows the remote computer as my FQDN of the farm name (is this standard for farm login?) Requires you to put a domain\username or [email protected] to proceed as opposed to a simple username

      pertinent settings:

      in TS Web Access | Configuration in I.E.:
      have the FQDN of the server name hosting the RemoteApp Web Access

      in DNS:
      have the 2 servers configured with an alias for load balancing

      in TSRemoteApp Manager under RemoteApp Deployment Settings:

      Terminal Server tab:
      have FQDN of the farm alias as set up in DNS
      require server authentication is checked (i've unchecked it with same results)

      TS Gateway tab:
      do not use gateway

      Digital Certificate tab:
      nothing checked to use one

      In IIS on Default Website:
      have Windows Authentication Enabled and no other authentications
      Last edited by jawz101; 19th February 2009, 00:00.

      Comment


      • #4
        Re: Windows 2008 Terminal Services login requiring domain prefix. Any way to change?

        AFAIK, the "issue" you're experiencing is a function of the RDP client, not the TS server. I believe this was a change that occurred with version 6.1 of the RDP client. Also, AFAIK there's nothing that can be done to change the behavior.

        However, you can configure the RDP client to save the credentials (in domain\username form) so that the Log On To field is populated with the domain name instead of the computer name.

        Comment


        • #5
          Re: Windows 2008 Terminal Services login requiring domain prefix. Any way to change?

          Just great. Now my users need to know what a fully qualified domain name is... Microsoft, if you're reading this that is bs

          Comment

          Working...
          X