No announcement yet.

Terminal Services not allowing connections

  • Filter
  • Time
  • Show
Clear All
new posts

  • Terminal Services not allowing connections


    I have a Windows 2003 Standard Edition Server (R2 SP2) on good IBM server hardware.

    I just demoted this server away from being the DC on our test domain today (not sure if this has anything to do with it).

    Terminal Services has been installed and successfully activated. Firewall ports opened.

    When you try to connect with the MSTSC client, it says "This computer cant connect to the remote computer". I have tried everything from rebooting the server, to reactivating terminal services licensing, to turning the firewall entirely off. For some reason I cannot get even one client to connect to the server.

    For some reason I feel that by removing the AD services from it, a certificate might be messed up, or maybe some system setting.

    Any ideas would be greatly appreciated.

    Thank you,


  • #2
    Re: Terminal Services not allowing connections

    TBH, if it was a DC before hand I would have rebuilt it.

    Can you connect via the IP address rather than DNS name?
    Have you tried enabeling remote desktop via my computer and remote access? I can't remember if installing TS services automatically does this.

    Michael Armstrong
    MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **


    • #3
      Re: Terminal Services not allowing connections

      Originally posted by Originally Posted by Norm Hughes from Melbourne SBS UG
      Yes, had foreknowledge of all your suggestions and I did check all.
      In fact, I rechecked them in case I was suffering from a Senior's

      But the Good News is, that with the help of MS, it's fixed. For the
      benefit of the group, the issue was that during the installation of the
      SP2 files, for whatever reason some files just don't get updated. One of
      these is the termdd.sys file; turns out that the SP2 version had not
      been copied to my Windows\System32\Drivers folder, and the older file
      just doesn't work with the balance of the Sp2 install. Easy when you
      This might be worth a look.
      Joined: 23rd December 2003
      Departed: 23rd December 2015


      • #4
        Re: Terminal Services not allowing connections


        I have resolved the problem. Based on the feedback that I got from multiple places, it is just easier to rebuild a server after is has been demoted out of the DC role. After rebuilding the server, everything worked correctly. I think the issue had something to do with the CA certificate that gets revoked when the DC is demoted.

        Thank you,