Announcement

Collapse
No announcement yet.

Cookie problems with roaming profiles in W2k3 Citrix/TS farm

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cookie problems with roaming profiles in W2k3 Citrix/TS farm

    Hi there,

    I have a problem I hope the learned people of this forum can help with..

    My workplace had a citrix environment with a single Citrix/TS (TS1) server (MF 4.5) and a single AD Domain controller (both W2k3 SP1) with roaming profiles (the user's profile was set to be \\server\profilesTS with some "%USERPROFILE%\Cookies" User Shell Folder entries). The decision was made to clone the TS server and make TS2 and TS3, thereby creating a Citrix farm, by renaming the cloned (now vmware'd) servers and reinstalling Citrix on them (due to the name change).

    All seemed to be trundling along nicely until it was noticed that, while TS1 downloaded cookies from the roaming profile location, had the session write to the c:\documents and settings\user\Cookies directory, then uploaded them on logout, TS2 and TS3 downloaded cookies from the roaming profile store, had the session write to the c:\documents and settings\user\local settings\temp\Cookies directory, then uploaded the c:\documents and settings\user\Cookies directory on logout, thus 1) ignoring the cookies that had been downloaded/cached on the local drive and 2) not uploading the cookies that had been created while the session was logged in.


    TS2 and TS3 are downloading and uploading the c:\documents and settings\user\Cookies directory perfectly (have tested this by insertion of a simple text file, it was uploaded and downloaded successfully) but they are not reading/writing cookies from/to the correct directory. The user does not experience this on TS1, all goes as it should do, they can access the cookies from their roaming profile. User's on TS2/3 can not access the cookies from their roaming profile


    I have seen on this page: http://www.unhsolutions.net/IE-Priva.../faq.html#tr_2

    that this situation can be caused by a damaged index.dat file (not sure if this is a cookie dat file or history or TIF etc).

    I have deleted my cached profile on all 3 servers and recreated it on all 3 by logging in, no difference. TS1 continues to place cookies in Documents and Settings\user\Cookies, TS2 and TS3 both download the cookies from the roaming profile but will not use them as the actual cookies for the session, instead using Documents and Settings\user\local settings\temp\<number>\Cookies where <number> is 3 or 8 or something similar..


    Can anyone help with this utterly frustrating situation please?

    Thanks for any help offered

    Steve

  • #2
    Re: Cookie problems with roaming profiles in W2k3 Citrix/TS farm

    Did you tried to delete the old TS profile on the TS1?
    Best Regards,

    Yuval Sinay

    LinkedIn: https://www.linkedin.com/in/yuval14, Blog: http://blogs.microsoft.co.il/blogs/yuval14

    Comment

    Working...
    X