No announcement yet.

Disable screensaver timeout on pc

  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable screensaver timeout on pc

    there is a gpo that enables a screensaver after 30minutes of inactivity. Can you tell me how i can disable this on an xp pc.

    Thanks in advance

  • #2
    Re: Disable screensaver timeout on pc

    You can

    1. change the setting
    2. remove the setting
    3. use Group Policy Filtering to exclude the XP machine from processing the GPO. The article talks about users but you can substitute computers or groups of computers.

    Another good reference
    And of course there's always

    Network Consultant/Engineer
    Baltimore - Washington area and beyond


    • #3
      Re: Disable screensaver timeout on pc

      I've set a default policy to enable password protected screen savers for all Authenticated users, this so that our office staff will not forget to lock their screens when they leave the workstations for an extended period of time.
      • I opened the Group Policy Manager
      • Drilled down to the Domain at Group Policy Management\Forest\Domains\Domain
      • Right clicked and chose to Create and Link GPO
      • When a GPO is created you can click on it, some details about the GPO are displayed at the right hand side of the screen. Most important which groups/users or computers that are affected by the policy. I set it to Authenticated users.
      • The I right clicked the GPO and chose Edit.
      • In the GPO I drilled to User config\Administrative templates\Control panel\Display and changed the settings to suit my needs.

      Then I created another policy just like the one I had before with the exception that I set the policy to affect a security group I call "Production computers", the Screen saver was set as disabled.

      When you start the Group Policy Manager and go down to Group Policy Management\Forest\Domains\Domain you can see that the policies are listed in the right hand area with a Link order, all I had to do now was to make sure that the Policy that disabled the Screen saver for the "Production computers" were executed before the policy affecting all "Authenticated users".

      In your case, just create a "Default policy" or change the exsisting Default policy at User config\Administrative templates\Control panel\Display and set the screensaver to Disabled.

      I hope this example can be of use. I'm not sure if you really have to change the order in which the policies are executed, but I remember it as so.

      By the way, make sure to take backups before you start working in the GPM!

      Last edited by Anders; 30th October 2006, 14:29.
      A wise man once said: "Assumption is the mother of all fu*k ups".

      Any advice I give is to the best of my knowledge, there is no guarantee what so ever that it will actually work in your particular scenario. I will not accept any responsibility for unexpected consequences, after all - you are taking advice from a complete stranger over the internet. =)