Announcement

Collapse
No announcement yet.

need help with a script applied by GPO

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • need help with a script applied by GPO

    Hello,

    I need to automate WebFeed insertion for Remote App Users at user logon.

    RDS 2012 R2 in place. Remote Apps are provided to W7 clients.

    Currently, WebFeed link must be inserted manually in each user's Control Panel\RemoteApp and Desktop Connections. There is no straight forward way from Microsoft.
    But there is a script and instruction I found on web...

    I followed instruction... Created GPO. GPO applies to user but nothing happens.
    Can somebody check the script and the instruction that I could wrongly applied.

    In instruction there is no word about changing something in the script but only wcx file that the script should use.
    I attach Script and reference file.
    Also I tried to run the script on the machine without GPO. Don't see the result.
    Check please if the script really should not be touched and some troubleshooting steps.

    Thanks

    ****************************
    INSTRUCTIONS from the link:
    http://www.concurrency.com/infrastru...rver-2012-rds/

    "Unfortunately Windows 7 clients are out of luck here. If you really want to use GPO to deploy RemoteApps to Windows 7 clients, then you have to jump through a few hoops.

    Create a new GPO and under User ConfigurationPoliciesWindows SettingsScripts, double click Logon and click the Show Files button. This will open an explorer window where you can copy files that will be saved within this GPO. Download the Install-RADCConnection.ps1 script from the TechNet gallery and save it there. Also create a new Text file named something like feed.wcx, open it in Notepad and paste in the following three lines of text:
    <?xml version=”1.0″ encoding=”utf-8″ standalone=”yes”?>
    <workspace name=”Enterprise Remote Access” xmlns=”http://schemas.microsoft.com/ts/2008/09/tswcx” xmlnss=”http://www.w3.org/2001/XMLSchema”>
    <defaultFeed url=”https://rds.domain.com/RDWeb/Feed/webfeed.aspx” />
    </workspace>
    Now select the PowerShell Scripts tab and click the Add button.

    Click Browse and select the .ps1 file and for the parameters enter the name of the wcx file. Click OK twice and you are ready to scope that policy to a set of users.
    Attached Files
    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

  • #2
    Re: need help with a script applied by GPO

    I changed the quotes to vertical (") from (”) that were in my wcx when copied the lines from web.

    Still not works.

    I checked Application log, PowerShell and RemoteApp in eventviewer.

    Everything is clean.

    Were I can check the script execution log?

    When the user with applied script logs in the icon of Remote connection appears for 10 seconds and disappears.

    Looks like it's trying...
    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

    Comment


    • #3
      Re: need help with a script applied by GPO

      did it again using the script and wcx in the link and after other tries it works.
      Last edited by mla; 14th February 2015, 21:25.
      "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

      Comment

      Working...
      X