Announcement

Collapse
No announcement yet.

GPO Not Applying

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPO Not Applying

    Running DC with Server 08 R2.
    Computers running Windows 7.

    I want to apply a registry setting to all computers within an OU.



    This is OU structure.

    Domain > Site Name > Computer OU

    I create the GPO and linked it to the OU and it does not apply.

    I've tried everything from forcing GPupdate and several reboots. No go.

  • #2
    Re: GPO Not Applying

    You're trying to apply a User setting to a Computer object. You should be applying this setting to an OU with users in it who would be logging into your domain. The PCs don't have to be in the same OU as the users, but the GPO as you've set it has to apply to the users, since it's a User setting.
    *RicklesP*
    MSCA (2003/XP), Security+, CCNA

    ** Remember: credit where credit is due, and reputation points as appropriate **

    Comment


    • #3
      Re: GPO Not Applying

      Originally posted by RicklesP View Post
      You're trying to apply a User setting to a Computer object. You should be applying this setting to an OU with users in it who would be logging into your domain. The PCs don't have to be in the same OU as the users, but the GPO as you've set it has to apply to the users, since it's a User setting.
      Maybe I am going down the wrong road and I want to fully explain what I am looking to do.

      What I want is to apply a setting to always show all icons and notifications in the task bar to all computers within an OU.

      The only way I could find to accomplish this was enforcing a registry setting within HKCU. Not sure if I can do it within HKLM.

      That being said, and you'll have to pardon me being a novice, what would be the steps taken within GP to accomplish this? I feel like I'm close.

      Comment


      • #4
        Re: GPO Not Applying

        Again, you're trying to apply a User setting to a Computer object. User settings apply to Users and Computer settings apply to Computers and never shall the two meet. That being said:

        If you want to apply specific user settings to users ONLY when they log on to THESE computers then in the GPO linked to the computer OU you need to configure Loopback Policy processing in Merge or Replace mode.

        Loopback Policy processing allows the USER settings from the GPO linked to the COMPUTER object to apply to users when they log on to THESE computers.

        Merge Mode = Merge the users normal GPO settings with these GPO settings.

        Replace Mode = Replace the users normal GPO settings with these settings.

        Comment


        • #5
          Re: GPO Not Applying

          Originally posted by joeqwerty View Post
          Again, you're trying to apply a User setting to a Computer object. User settings apply to Users and Computer settings apply to Computers and never shall the two meet. That being said:

          If you want to apply specific user settings to users ONLY when they log on to THESE computers then in the GPO linked to the computer OU you need to configure Loopback Policy processing in Merge or Replace mode.

          Loopback Policy processing allows the USER settings from the GPO linked to the COMPUTER object to apply to users when they log on to THESE computers.

          Merge Mode = Merge the users normal GPO settings with these GPO settings.

          Replace Mode = Replace the users normal GPO settings with these settings.
          You solved my issue. Thank you very much.

          I chose Merge. And for those curious, here is the solution taken from this site:

          http://social.technet.microsoft.com/...sing-mode.aspx

          To enable “Loopback processing Mode”

          Using Group Policy Management Console, edit the GPO you desire, expand Computer Configuration\Policies\Administrative Templates\System\Group Policy,
          and then double-click User Group Policy Loopback Processing Mode.

          Then select the appropriate option (Replace or Merge).

          Comment


          • #6
            Re: GPO Not Applying

            Glad to help...

            Comment

            Working...
            X