Announcement

Collapse
No announcement yet.

GPO Folder permissions not propagating to subfolders

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPO Folder permissions not propagating to subfolders

    Having a frustrating problem with this. Basically, on Windows XP this works fine, but on Win 6.x it does not. (info: server 2008 domain)

    We are using a program which needs full access to the "%AllUsersProfile%/application-name" folder for the user, so that it can create subfolders and download data from the server. This is set in a GPO and the permissions are set on this folder correctly. However, in Windows 6.x the subfolders are created, but NO permissions are set on the folders at all, thus the user cannot access them in any way, thus the program fails with permission errors. Any ideas as to what I have done wrong? Usually very good with GPO's but this one has me stumped, as it works on XP...
    James
    MCP

  • #2
    Re: GPO Folder permissions not propagating to subfolders

    Just a wild idea. Try moving the User folders to a different location eg Users folder and try again. Just on one machine obviously. Moving them on Win7 or Win6.x is a pain and not as easy as XP but if this works them I am sure Rems will have a script for it.

    He may even be able to script a permission change without the move.
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

    Comment


    • #3
      Re: GPO Folder permissions not propagating to subfolders

      Originally posted by :)

      Just a wild idea...
      ... I am sure Rems will have a script for it
      This makes it do it:
      gpupdate /force
      The force switch is required!


      To implement this in the GPO:
      1. under: Computer Configuration\Policies\Administrative templates\System\Logon
        enable "Always wait for the network at computer startup and logon to the computer"

      2. Under: Computer Configuration\Policies\Windows Settings\Scripts (.../...)
        ADD Startup script:
        - Script name: gpupdate.exe
        - script parameters: /Target:Computer /Wait:0 /Force

      Yes a pretty ugly workaround is'nt it.


      /Rems
      Last edited by Rems; 16th December 2011, 11:25.

      This posting is provided "AS IS" with no warranties, and confers no rights.

      __________________

      ** Remember to give credit where credit's due **
      and leave Reputation Points for meaningful posts

      Comment

      Working...
      X