Announcement

Collapse
No announcement yet.

GPP: Trying To Set HKEY_CURRENT_USER Permissions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPP: Trying To Set HKEY_CURRENT_USER Permissions

    Hi guys,

    I'm trying to set full read/write permissions on two registry keys using Group Policy Preferences as the editor.

    The keys are:

    HKEY_CURRENT_USER\Software\Fast React\Database
    HKEY_CURRENT_USER\Software\Fast React\Translate

    I've already set the registry key settings that I want to be modified (image attached), but unfortunately they only work when a user has local admin rights (which I'm trying to move away from).

    I understand an .ini file might be able to set registry key permissions so have created one with what I think is needed (file attached), but am unsure how to make this apply for each user login even when they don't have any local admin rights.

    Is this something anyone has encountered here?

    Many thanks,

    Jez
    Attached Files

  • #2
    Re: GPP: Trying To Set HKEY_CURRENT_USER Permissions

    Have you tried setting them for the computers, so they will be applied under (IIRC) the local system account, not the user account
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: GPP: Trying To Set HKEY_CURRENT_USER Permissions

      Hi Ossian,

      Thanks for the suggestion. I've just tried it but unfortunately it still doesn't apply the registry entries, unless the user has admin rights. Any other ideas would be much appreciated.

      Thanks,

      Jez
      Attached Files

      Comment

      Working...
      X