Announcement

Collapse
No announcement yet.

GPO for user works on one computer but not another???

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPO for user works on one computer but not another???

    OK, I know I am probably going to get a hard time, but here it goes. I have been struggling with this for a week, and have been all over Google (and here).

    Here is our Domain network design:

    Windows 2008 Standard AD Servers w/ DNS, DHCP, GMPC, and the whole works....
    Clients are Win7 Professional (All within 6 months old)
    Same Domain
    Same Network
    Same Building
    Happens to several users...
    Users are part of Authenticated Users, Domain Users
    Computers are part of Domain Computers

    Issue at hand is Screen Lock after 10 minutes of no activity.

    I have a few users that log onto a few different computers. They are not logging into the same computer though. UserA can be at his desk, and his screen wil lock after 10 minutes of no activity, but then UserA will go to the 3rd Floor training room, and his screen will never lock (using a different computer) even after 30 minutes. UserB can be at her desk and her screen Never locks, but I have her sign onto a computer in my office, and the screen will lock after 10 minutes of no activity. This Happens to several users.

    What I have done:
    - perform gpupdate /force (many times over a week)
    - compare gpresult /r and gpresult /z on each machine with no difference on any one them (many times over a week)
    - created a brand new (not a copy / paste) screen-lockout GPO (same results as old one)
    - rebooted computers (many times over a week)
    - request another user to log onto a computer that will not lock screen (it locked for them)
    - checked user security in AD to be use they are part of the Domain, about 10 times or more
    - used Group Policy Modeling in the GPMC to compare userA to computerA/UserA to ComputerB - results are the same for each. compared other users too.
    - Checked DNS to be sure all information was okay and dns had no issues.
    - restarted Netlogon service, dns server, dns client services on the AD Servers.

    I have exhausted my entire thought of this.

    I have created many many GPOs, and can usually fix them when issues arise, but this one has be baffled.

    if anyone has an idea, thought, or anything, I would be willing to give it a shot, and reply back with the results.

    If there are any other screenshots you would like to look over, please let me know.

    Thanks, Brent
    Attached Files

  • #2
    Re: GPO for user works on one computer but not another???

    Have you checked the event logs on the computers with problems?

    Are all computers in the same OU?
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

    Comment


    • #3
      Re: GPO for user works on one computer but not another???

      Yes, I have checked the Event Viewer of each computer.
      I see no errors, but only thing I see related to GP is the below:

      The Group Policy settings for the computer were processed successfully. New settings from 8 Group Policy objects were detected and applied.

      No, we have 2 different OUs for the computers (for each site in the domain, see below) but the computers being in a different OU would not have an affect on this, the GPO is User based. The GPO is set under the Users/Office OU.

      Domain
      -Site1
      --Computers (OU)
      ---Workstations
      ---Laptops
      --Users
      ---Office
      ---Salesmen

      -Site2
      --Computers (OU)
      ---Workstations
      ---Laptops
      --Users
      ---Office
      ---Salesmen
      Attached Files

      Comment


      • #4
        Re: GPO for user works on one computer but not another???

        Originally posted by brent_c76 View Post
        No, we have 2 different OUs for the computers (for each site in the domain, see below) but the computers being in a different OU would not have an affect on this, the GPO is User based.
        These are user-level settings, but computers being in different OUs could have other GPO settings that are different that might impact this and it is also possible to target user-level settings based on the computer using loopback processing.
        Gareth Howells

        BSc (Hons), MBCS, MCP, MCDST, ICCE

        Any advice is given in good faith and without warranty.

        Please give reputation points if somebody has helped you.

        "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

        "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

        Comment


        • #5
          Re: GPO for user works on one computer but not another???

          So when you compared the gpresult from both computers they were applying the exact same GPOs?

          On a computer where it locks for one user and doesn't for another I would get a list of running processes and compare them for the users. See if a program is running on the user that doesn't lock that isn't running on a user that does lock. It might be that a program is keeping the computer from being inactive.
          Regards,
          Jeremy

          Network Consultant/Engineer
          Baltimore - Washington area and beyond
          www.gma-cpa.com

          Comment


          • #6
            Re: GPO for user works on one computer but not another???

            Update:

            I placed the setting in the GPO for loopback procesing. I set it to "Merge". No luck after setting this.

            I also compared the the processes ruinning on each computer, all compared computers are running similar processes (All computers are based on the same image), with the exception of the laptops, they are running a couple of processes for the HP webcam, and other hp items. I did kill all of the process to make it similar to a computer that is working, and I did not have any luck with that either.

            here is another thing i tried, I logged a different user onto the trouble computer, and i let the screen sit for quite some time, and it did not lock for her either. Whereas, it does lock for her at her desk.

            ---- Starting to think it is a computer thing? Perhaps? Anyone else got an idea?

            Comment


            • #7
              Re: GPO for user works on one computer but not another???

              For the users who don't get the screensaver, check their display properties. Is the screensaver set as you would expect and is therefore just not starting for some reason, or are the settings not being applied at all.
              Gareth Howells

              BSc (Hons), MBCS, MCP, MCDST, ICCE

              Any advice is given in good faith and without warranty.

              Please give reputation points if somebody has helped you.

              "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

              "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

              Comment


              • #8
                Re: GPO for user works on one computer but not another???

                I have checked the users Display properties many many times, just to assure myself it is set. the Time for lockout as well as the "on resume, display the log in screen" is checked and is greyed out (just as I expect),

                the screensaver is set to blank, starfield, ribbons, etc.... none of them are set to "No screen saver".

                The above settings are coming from the same GPO as the one to "turn on" the screensaver" that is what i cannot understand.?.?.?


                Thanks, brent

                Comment


                • #9
                  RESOLVED! Re: GPO for user works on one computer but not another???

                  Resolved!

                  Issue Resolved!
                  I brought a “trouble” computer to my office. I logged on as the user just as she did at her desk. I waited my 10 minutes, and the screen locked. I tested this a few more times before taking the computer back to the user’s office just to prove to myself that the issue was real resolved. Needless to say, the issue was NOT resolved! I then began to think what the differences were between my office and her office. The mouse she was using was a Wireless Microsoft Mouse. I checked a few things out with the mouse, it seemed to be A-Okay! But just for my own satisfaction, I came to my office and got her a wired mouse to use. When I plugged it in, and she waited her 10 minutes to allow the screen to lock, BINGO! The screen locked just as it should have all along. She still demanded to use a wireless Mouse, so, I went to the store and purchased her a New Logitech Wireless mouse. Issue Resolved.!.!
                  Lesson learned!
                  Finally relieved!

                  Thanks to all of you that provided any assistance.
                  Brent

                  Comment


                  • #10
                    Re: GPO for user works on one computer but not another???

                    Well done for cracking it I think we can definately chalk this one up to PEBKAC

                    Now to get rid of these pesky wireless mice... go to your local value store and buy a handful of cheap microwave ovens
                    Gareth Howells

                    BSc (Hons), MBCS, MCP, MCDST, ICCE

                    Any advice is given in good faith and without warranty.

                    Please give reputation points if somebody has helped you.

                    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

                    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

                    Comment


                    • #11
                      Re: GPO for user works on one computer but not another???

                      nice work mate !
                      just reassures my theory that it's ALWAYS users :P

                      congrats for figuring it, and coming back and telling us what the answer was!
                      this has been a really well put together thread!
                      Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                      Comment

                      Working...
                      X