Announcement

Collapse
No announcement yet.

Default File Associations GP not working at first login

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Default File Associations GP not working at first login

    Last year I setup a Group policy to set file associations it worked. Now its not working anymore. The only association I am setting is .PDF to Adobe Reader vs Edge. I am using "Set a default associations configuration file" Setting ( Have attached the XML file) . I have run an RSOP and see the policy applying and even see the entry in the registry (See attached screenshot) The problem is on Windows 10 703 its just not working the PDF setting is still set to Edge. What I've found is that if I login as a user it doesn't work, if I log off and back on the next login it applies (even though its a machine not a user policy) We are a school without assigned machines so the logins are almost always first time is there any way to get this policy to apply the first time?
    Attached Files

  • #2
    Have you tried changing the policy processing to synchronous? That should ensure policies are downloaded and applied every boot/logon
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Yes I have, I also found this last night


      I found this link from Adobe with basically the same instructions I was already doing

      https://www.adobe.com/devnet-docs/ac...pdfviewer.html

      AT the bottom it says this "
      1. As of 5th Feb 2016, it is a known limitation of Windows 10 that when new user is created on the machine after enforcing the GPO Policy, then on first login ownership is not set. However, the correct settings are applied on subsequent logins."

      So its possible Microsoft changed something to make this method stop working. So now I don't know what to do

      Comment

      Working...
      X