Announcement

Collapse
No announcement yet.

GP Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GP Issue

    Hi all,

    I have AD running on a Server 2008 R2 box and have created a group policy stating that, when a domain user logs in to a client, I want IE to go through a proxy of 10.34.0.42 on port 8080.

    When logging into my Windows 7 x64 laptop, it works. I get the proxy setting in my IE.

    When logging on to any of my other Server 2008 R2 (x64) servers, it also works.

    BUT... Any other user logging onto any other client (XP Pro), and they do not get the setting...

    In addition, if I log on to a Server 2003 (32-bit) server, I also do NOT get the setting.

    I've tried everything I can think of, and my associate and I are pulling out our collective hair... Help! Thanks!

    Chris

    Huh?

  • #2
    Re: GP Issue

    Run RSOP and check it is being applied
    Are you setting policies or preferences?

    Have you applied the "client side extension" patch to your XP and 2003 boxes?
    http://www.windowsnetworking.com/kba...XPDevices.html
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: GP Issue

      Hi there, Ossian.

      To answer your "client side extension" question, yes AND no. I have over 200 XP clients. I would estimate that 150 or so have the most recent Microsoft Updates on them, and as such, they should have it.

      However, to test this I specifically chose one XP machine and looked to see if it had the KB943729 patch. It did not. So I manually installed it via the site you linked to. I then removed the proxy settings I had manually entered and rebooted to see what it would have upon coming back up.

      I logged into the domain as the domain admin.

      Upon checking, the "Use a proxy server for your LAN" box WAS now checked. However, the address field was blank and it was set to port 80.

      Should be set to 10.34.0.42 on port 8080.

      So it's now picking up something, just not the right thing...

      As for running RSOP, I will check that when my infrastructure guru arrives as I'm not enough of an expert to play with such things. He'll be in shortly and I'll get back to you.

      Thanks for the help so far! This is a setting necessary for our school, and we have to be operational very soon. Your help is greatly appreciated!

      Best,

      Chris

      Comment


      • #4
        Re: GP Issue

        It is a "policy", not a "preference" by the way... Thanks!

        Comment


        • #5
          Re: GP Issue

          Do you have a WSUS server -- if so, rolling out the patch will be a doddle!
          Also, I always assume GP settings will not be fully applied until you've gone through at least 2 full reboots

          Moving thread to GPO forum as best location...
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment


          • #6
            Re: GP Issue

            Two full CLIENT reboots?

            EDIT: No SUS...
            Last edited by WorldBuilder; 19th August 2010, 17:13. Reason: Added Info

            Comment


            • #7
              Re: GP Issue

              Yes -- I know GPOs should apply without rebooting / logging off where they can, but the reality seems to be that something misses out unless you reboot... and then once more for luck
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                Re: GP Issue

                Hi again, Ossian!

                Got it working... My infrastructure guy was the one DOING this mainly, and it turns out he was simply doing it wrong. Happens to the best of us. When I looked, I noticed that he was actually setting "preferences" after all, not policies as you asked about above.

                I removed that and went to User Configuration>Windows Settings>IE Maintenance to set the proxy.

                Works like a champ!

                Thanks!

                Chris

                Comment


                • #9
                  Re: GP Issue

                  Well done!

                  Note WSUS is worth investigating -- free, easy to install / manage and really takes a load off you as admin!
                  Tom Jones
                  MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                  PhD, MSc, FIAP, MIITT
                  IT Trainer / Consultant
                  Ossian Ltd
                  Scotland

                  ** Remember to give credit where credit is due and leave reputation points where appropriate **

                  Comment

                  Working...
                  X