No announcement yet.

Publish Software on the Network by GPO

  • Filter
  • Time
  • Show
Clear All
new posts

  • Publish Software on the Network by GPO

    Hi Everyone,

    I'm having problems seeing the published software which I've created by GPO.

    I've tried Publishing using both Computer Settings and User Settings in the GPO editor and neither seem to work.

    I've setup categories and I see those categories in Add and Remove Programs in the Control Panel but not the MSI applications (from the shared folder).

    I've created the necessary packages by GPO.

    I've tested the permissions on the shared folder using my regular domain user account (non admin rights) and I was able to run and modify within the folder.

    I've ran gpresult and I see the GPO applied.

    OS: Win server 2003 w/SP2
    Shared Folder location: \\FileServer\Software_Published

  • #2
    Re: Publish Software on the Network by GPO

    I've rebooted my PC and it works now. I thought a GPUPDATE /force with a loggoff would suffice but I guess I was wrong.


    • #3
      Re: Publish Software on the Network by GPO

      It seems that whenever you're in a hurry to test stuff, you actually end up wasting time troubleshooting. This is the case with GPOs, as you can often simply be having issues with inter-DC replication, with your machine's GPO synchronisation, etc.

      Here's two tips:
      rsop.msc is your friend, in order to see what is applying and from what GPO it's coming from

      C:\windows\security\logs\winlogon.log almost always contains very valuable information regarding GPOs, can be very useful to troubleshoot problem.

      Glad to see you're not having problems anymore!
      VCP on vSphere (4), MCITP:EA/DBA, MCTS:Blahblah


      • #4
        Re: Publish Software on the Network by GPO

        As a friendly reminder, the default time that group policy pushes updates is 90 minutes. So from the time you create something new, it can take upwards of 90 minutes for a machine to get the policy. Running gpupdate /force, as you found out, forces an update manually. Whenever I test GPO stuff, gpupdate /force becomes extremely useful.

        Otherwise, a regular logon/logoff will only apply user level settings. Computer level settings will usually need a full reboot (hence why when XP starts up is says 'applying computer settings'). If you haven't done a gpupdate /force, you'll usually need 2 reboots to see any computer level changes - 1 to refresh group policy, and then another to actually apply changes.