Announcement

Collapse
No announcement yet.

IE Policy not applying on certain workstations

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IE Policy not applying on certain workstations

    Hi,

    I am having a problem with IE settings on a percentage of our workstations.

    I am simply trying to amend the default homepage and some site to zone assignments and have been using the IE Maintenance policy settings to do this.

    On 95% of our workstations the settings correctly apply and the settings within IE change to what I want. On the other 5% the policy is being applied according to GPRESULT but the settings aren't being changed within IE.

    I have tried to resolve it in a variety of ways including.

    Resetting the browser settings in the policy.
    Tried using browser preference mode
    Enabling the Apply Internet Explorer Settings on each login, even if they haven't changed.
    Creating a brand new policy and applying it to the affected workstations.
    Applied the MS hotfix (can't remember the number) that alledgedly resolves this issue.
    I have also tried using the adm templates for IE.

    None of this works and its driving me nuts as I can't change everyone over to use the new intranet page as their homepage or set the web applications pages to be in the correct security zone for the 5% of users this doesn't apply to.

    Looking on the workstations there aren't any errors being reported when applying group policy and there are no real clues to anything being wrong in the event logs.

    Does anyone have any other ideas I can try?

    Thanks.
    Jonathan

  • #2
    Re: IE Policy not applying on certain workstations

    rsop.msc to show the resultant settings from GP application.

    gpupdate /force if the settings shown are not what they should be.
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

    Comment


    • #3
      Re: IE Policy not applying on certain workstations

      Same thing happened to me a year ago . Few clients home page and other IE settings were not updating according to group policy. I tried and checked so many thngs but nothing seems to working. I rename user profile and asked them to log back in. I do not what is technical logic behind it but all IE explorer setting via group policy were applied. So if I get this error I recrete user profile . If changes do not apply to terminal session recreate their terminal profile. You know who to recrete users profile?

      Comment


      • #4
        Re: IE Policy not applying on certain workstations

        Sorry gforceindustries should have added to my list of attempted fixes that I had run gpupdate /force with no luck.

        I have read some anecdotal stuff elsewhere as well about roaming profiles being an issue sometimes for IE GPO's..

        Comment


        • #5
          Re: IE Policy not applying on certain workstations

          Delete the local copy of the profile then. Or try logging in as that user to a machine they've not used before.
          Gareth Howells

          BSc (Hons), MBCS, MCP, MCDST, ICCE

          Any advice is given in good faith and without warranty.

          Please give reputation points if somebody has helped you.

          "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

          "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

          Comment


          • #6
            Re: IE Policy not applying on certain workstations

            Originally posted by j0nn13 View Post
            Sorry gforceindustries should have added to my list of attempted fixes that I had run gpupdate /force with no luck.

            I have read some anecdotal stuff elsewhere as well about roaming profiles being an issue sometimes for IE GPO's..
            Roaming profiles are a good idea that never really worked properly, the longer you use them or the bigger the profile the worse things get. If your users don't hotdesk I'd switch them to My Docs redirection or something like that, it'll speed up logon times and reduce support calls IME.

            On XP and earlier machines you can append .old to the end of the profile directory whilst logged on as a different user and then log the original back on. That preserves the profile and allows copying of any files stored in silly places (Like the desktop, the universal dumping ground for users who don't pay attention ). Doesn't work in Vista though, you have to mess with the registry to delete a profile cleanly and when you edit the reg it deletes the folders as I recall, so you might want to back up the profiles directories first in that instance.
            BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
            sigpic
            Cruachan's Blog

            Comment


            • #7
              Re: IE Policy not applying on certain workstations

              I believe Microsoft now recommend that folders be redirected rather than users having roaming profiles. The only part of the profile you wouldn't want to redirect is also a folder which wasn't part of the roaming profile, which is Local Settings.
              Gareth Howells

              BSc (Hons), MBCS, MCP, MCDST, ICCE

              Any advice is given in good faith and without warranty.

              Please give reputation points if somebody has helped you.

              "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

              "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

              Comment


              • #8
                Re: IE Policy not applying on certain workstations

                I have been given a list of users by our intranet team who are not having the changes applied. Having a look through it, it appears that it is about a 50/50 split of users who have and have not got roaming profiles, so I am not even sure its the only factor?

                I have checked in the following path on the users PC's:

                %Windir%\System32\Group Policy\User and there are none of the files that you would expect to be there if the policy was applying correctly ie. install.ins, \Branding\Adm\inetset.adm

                Given that this is happening to some users without roaming profiles, in exactly the same manner as those with roaming profiles, I am not convinced that the RPrfs are the cause?

                Any other ideas?

                Comment


                • #9
                  Re: IE Policy not applying on certain workstations

                  You can try by enabling the IEM policy "Process even if the Group Policy objects have not changed"
                  At: Computer Configuration\Administrative Templates\System\Group Policy\Internet Explorer Maintenance policy processing


                  \Rems

                  This posting is provided "AS IS" with no warranties, and confers no rights.

                  __________________

                  ** Remember to give credit where credit's due **
                  and leave Reputation Points for meaningful posts

                  Comment

                  Working...
                  X