No announcement yet.

Script stopped working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Script stopped working

    I have a DC that had a computer policy to run a script at startup. And it worked fine!
    Now, that policy does not run!
    Here goes some more details:
    1. If i run the script manualy as Admin it works just fine so the problem is not the script.
    2. the script is in another server and not on the DC
    3. The full path is rigth ex. \\192.16....\Thecript.vbs
    4. If i manualy copy the scritp into sysvol/policy it runs bus gives an error that i have no permission.
    5. The script simple copies a file into the windows folder so it CANNOT be a user policy!
    6. Any other computer policy work just fine except scripts.
    7. if i run gpresult on the WSstion the policy is there.
    8 . Server 2003 and WS xp sp2

    Any help!?!?!?

    Last edited by mom; 23rd May 2009, 12:31.

  • #2
    Re: Script stopped working

    First thing to check is if the GPO has created the registry entry for the startup script to run and using its correct UNC path and arguments. You should find the entry in a subkey on the clients in this registrykey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\ Microsoft\Windows\System\Scripts\Startup

    Secondly, the USERINIT process owns the job of running the Group Policy scripts for each startup, logon, logoff, and shutdown event. Therefore, for possible startup script errors check the application_events on a client for records with UserInit as the source.

    In order to allow the build-in\System of each computer to execute the script file,
    - The share and NTFS permissions on \\192.16...\share\Thecript.vbs should at leased allow "read and execute" for "Authenticated Users".
    - The server should be a member of the domain and, assigned a static IP address, and registered in dns.

    Finally, I'd like to have a look at the actual startup script too. Well, infact it is not a correct assumption that the problem cannot be with the startup script itself just because it run succesfully when started manually.

    Originally posted by mom View Post
    4. If i manualy copy the scritp into sysvol/policy it runs bus gives an error that i have no permission.
    Try adding the Active Directory Domainname *.domain.local to the list of trusted domains in the 'Intranet zone' of Internet Explorer on your test computer.


    This posting is provided "AS IS" with no warranties, and confers no rights.


    ** Remember to give credit where credit's due **
    and leave Reputation Points for meaningful posts