No announcement yet.

Common File Open Dialogue in Office 2003

  • Filter
  • Time
  • Show
Clear All
new posts

  • Common File Open Dialogue in Office 2003

    Hi All,

    I am having some trouble with a desktop lockdown policy and hope that you can help.

    I am trying to prevent users from saving files to local drives. I have enabled the following settings;

    User Settings

    Windows Components/Windows Explorer
    PolicySettingHide these specified drives in My ComputerEnabled
    Pick one of the following combinationsRestrict C drive onlyPolicySettingHides the Manage item on the Windows Explorer context menuEnabledNo "Computers Near Me" in My Network PlacesDisabledNo "Entire Network" in My Network PlacesDisabledPrevent access to drives from My ComputerEnabled Pick one of the following combinations Restrict C drive onlyPolicySettingRemove Security tabEnabledRemove Shared Documents from My ComputerEnabled
    PolicySettingDon't display the Getting Started welcome screen at logonEnabledPrevent access to registry editing toolsEnabledDisable regedit from running silently?YesPolicySettingPrevent access to the command promptEnabledDisable the command prompt script processing also?NoPolicySettingTurn off AutoplayEnabledTurn off Autoplay on:All drives
    Start Menu and Taskbar

    PolicySettingLock the TaskbarEnabledPrevent changes to Taskbar and Start Menu SettingsEnabledPrevent grouping of taskbar itemsEnabledRemove links and access to Windows UpdateEnabledRemove My Documents icon from Start MenuEnabledRemove My Music icon from Start MenuEnabledRemove My Network Places icon from Start MenuEnabledRemove My Pictures icon from Start MenuEnabledRemove Network Connections from Start MenuEnabledRemove Run menu from Start MenuEnabledRemove user name from Start MenuEnabledRemove user's folders from the Start MenuEnabled

    Control Panel

    PolicySettingForce classic Control Panel StyleEnabledShow only specified Control Panel appletsEnabledList of allowed Control Panel appletsaccess.cplCONTROL "C:\Program Files\Common Files\System\MSMAPI\1033\MLCFG32.CPL"desk.cplinetcpl.cplMailmain.cpl

    This caused an error when users tried to open a file from within a program (This operation has been cancelled due to restrictions in effect on this computer". I deduced that it was the common file open dialogue defaulting to the My Documents or Desktop folders which where now restricted by the "Prevent access to drives from My Computer" setting.

    I created the following policy to deal with the open dialogue problem;

    User Settings
    Windows Components/Windows Explorer/Common Open File Dialog

    Policy SettingItems displayed in Places Bar EnabledPlaces to display:Item 1 MyComputerItem 2 Z:\Item 3 G:\Item 4 DesktopItem 5 http://intranet/documents/
    And this one to deal with the fact the desktop doesn't disapear from the dialogues;

    User Settings
    Windows Settings
    Folder Redirection
    Setting: Basic (Redirect everyone's folder to the same location)
    Path: \\fileserver\Roaming Profiles\%USERNAME%\Desktop

    Grant user exclusive rights to DesktopDisabledMove the contents of Desktop to the new locationEnabled
    Policy Removal BehaviorLeave contents

    This all works for programs like notepad, paint and third party apps but not for Office 2003. With Excel, Outlook, etc I still get the "Operation has been cancelled..." error.

    Any ideas what else I need to do?

    Thanks in advance,

    Last edited by smallgreen; 13th January 2009, 15:30.

  • #2
    Re: Common File Open Dialogue in Office 2003

    For office application, you should configure the 'File Locations' settings. This can also be done with GP (you'll have to use the ADM files which comes with office)

    BTW, it is not recomended to use the 'Grant user exclusive rights to Desktop'. This way even your, as administrator, will not be able to access the folder.


    • #3
      Re: Common File Open Dialogue in Office 2003

      Hi Smart-X,

      I've installed the Office11.adm template; where do I find the File Location settings?

      Good catch with the exclusive rights, I had this un-set initially but it got missed in the shuffle while I was recreating these policies.



      • #4
        Re: Common File Open Dialogue in Office 2003

        The default 'File Locations' setting is specific to each application.
        Load each application's ADM file and configure it seperately.
        BTW, I think it will be better if you redirect My Documents and Application Data. Then you won't have to change the default file locations.


        • #5
          Re: Common File Open Dialogue in Office 2003

          Thanks X, I will try both methods.



          • #6
            Re: Common File Open Dialogue in Office 2003

            I added all the Office 2003 adm files to the GPO but still couldn't find the File Locations setting you refer to. Could you please post the path to these setting?

            I also tried redirecting My Documents but it seemed to do an offline syncronise with the files on log off which panicked me. I dont want network files stored in any way on local machines.

            Is it really doing a syncronise; I assumed that it just set the location of the My Documents folder to the path set in the GPO (in this case the users home folde). This is what I set;

            User Configuration
            Windows Settings
            Folder Redirection
            My Documents
            Setting: Basic (Redirect everyone's folder to the same location)
            Path: \\%HOMESHARE%%HOMEPATH%

            Options: Grant user exclusive rights to my Documents Disabled
            Move contents of My Documents to new location. Disabled
            Policy removal behaviour. Leave contents



            • #7
              Re: Common File Open Dialogue in Office 2003

              Regarding the offline files, you can Disable offline files in the following ways:
              A. using GPO (Computer Configuration --> Administrative Templates --> Network --> Offline Files)

              B. Disable Caching on the share itself (Properties of the shared folder --> Sharing Tab --> Caching --> Uncheck 'Allow caching...')

              If your goal is to stop users from saving files locally, I believe you should do the redirection of My Documents.

              If you still want to go with the Office ADM, these are the paths (All under User Configuration --> Administrative Templates:
              Microsoft Office Word 2003 --> Tools | Options... --> File Locations

              Microsoft Office Excel 2003 --> Tools | Options... --> General --> Default File Location

              Microsoft Office PowerPoint 2003 --> Tools | Options... --> Save --> Default Files Location

              Outlook - I'm not sure, but I think it also uses the word's location