Announcement

Collapse
No announcement yet.

cannot appy control panel policy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot appy control panel policy

    Hi,
    I have a terminal server for couple of users and want to tight it a bit...
    I created OU Terminal and placed TS there.
    Right click OU Properties GPO. In GPMC created new policy and linked it to OU. Edited it. Under User Admin Templ Enabled - Disable control Panell. Run gpupdate. Forced.
    .... Policy is not applied.
    What I did wrong or missed?
    Last edited by mla; 17th October 2008, 03:47. Reason: Could you please remove this thread. It became very long because of my questions. I clarified a lot. But really think that it will not be valuable for others.
    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

  • #2
    Re: cannot appy control panel policy

    User settings are applied to users based on the OU that the user objects are located in. If you want to apply specific settings to users only when they log on to the TS, then look at using GP loopback processing.

    Comment


    • #3
      Re: cannot appy control panel policy

      I found an article about loopback processing but couldn't find security settings for not applying this policy to administrators. In the article it was not clear and I couldn't figure it out

      Thanks for pointing me in right direction.

      I have to clearly read loopback policy.
      "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

      Comment


      • #4
        Re: cannot appy control panel policy

        Use security filtering on the GPO so that it applies only to specific users or groups of users. Administrators will get READ but not APPLY gpo settings which means they will not be affected by the GPO.

        Comment


        • #5
          Re: cannot appy control panel policy

          I see WMI filtering
          Where is Security filtering.
          Don't see any button or link or menu
          "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

          Comment


          • #6
            Re: cannot appy control panel policy

            In GPMC, select the GPO in the left pane, in the right pane you will see several tabs, one of them is the Scope pane, at the bottom you'll see a Security Filtering section, this is where you apply security filtering for the GPO.

            Comment


            • #7
              Re: cannot appy control panel policy

              I added administrators. In properties: General Members Members of and Managed by tabs

              Cannot find: not APPLY gpo settings

              This where I am lost...
              "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

              Comment


              • #8
                Re: cannot appy control panel policy

                You don't add Administrators, you add the group that you want the GPO to apply to. Administrators will automatically get READ, but not APPLY permissions on the GPO. Your user group will get APPLY permissions to the GPO, which means that the GPO will apply to them.

                Comment


                • #9
                  Re: cannot appy control panel policy

                  Joe,

                  I created Loopback policy for OU where my TS server placed.
                  In users I have Disable Control Pannel - Enabled.

                  In Security filtering I have authenticated users.
                  I removed Administrators as you suggested.
                  I placed them here by thinking that I will be able to apply
                  :not APPLY gpo settings: for them, since I have Authenticated users in security filtering. I didn`t create a group for TS users (probably I have to do).

                  My TS users now are in local TS server Remote Users group.
                  I guess here is the problem.

                  Breaf, my GPO not works.
                  Please correct me.

                  Thx.
                  "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

                  Comment


                  • #10
                    Re: cannot appy control panel policy

                    Joe,
                    I checked today again.
                    It works fine.
                    So I have :
                    Loopback policy Enabled

                    And restricted Control panel.

                    One little problem
                    As I mentioned in security filtering I have Auth. Users.
                    Administrators are authenticated Users. So now I cannot see Control Panel when logged in as admin.
                    If you remember I wanted to add Administrators to Security filtering and assign not apply GPO for them.
                    You told that they will not be blocked by default.

                    I am a click away for make it right I cannot find a security tab in properties. It should be somewhere.
                    Anyway I clarified a lot of things.
                    Don't know why after running gpupdate my GPO didn't take effect. But today it works.

                    Please help with not apply gpo to admins.
                    Thx.
                    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

                    Comment


                    • #11
                      Re: cannot appy control panel policy

                      Create a group for the users that you DO want the policy to apply to and add the users to the group. Add this group to the security filtering of the GPO and remove Authenticated Users. This should accomplish what you want.

                      Comment


                      • #12
                        Re: cannot appy control panel policy

                        Joe,
                        I just double checked Security filtering.
                        Administrators were there. Probably I didn't delete them.
                        So now Auth. only is there.

                        Sure I will create a group for TS. I understand that it will not affect users from this group in other way - TS server login only.
                        I understand Loopback policy.

                        Why my GPO changes not taking immediate effect?
                        And I would like to know where is the security for users i found some screenshots on web it's there after choosing GPO tab.
                        In my case I have Open button that brings me GPMC.
                        Where is Security? Cannot find it in Security filtering.

                        Thanks for your time. I have to learn well GPO. Never had time for this.
                        "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

                        Comment


                        • #13
                          Re: cannot appy control panel policy

                          GPO settings generally are only applied when you reboot the computer (for computer settings) or at logon (for user settings). So in your case, you should log off and back on to see the settings applied. I don't really understand your question about security. Could you rephrase your question?

                          Comment


                          • #14
                            Re: cannot appy control panel policy

                            please see this link
                            http://www.msterminalservices.org/ar...up-Policy.html

                            on third screenshot (Loopback Policy properties) Security tab appears...
                            I cannot get this ...
                            I read about policy replication on Technet.
                            Sure Logged off and on but my user policy not working immediately (and it's SBS network).

                            I will try to check more on applying GPO.
                            Actually I can try to restart TS server. Loopback policy is computer policy. So may be this is it in my case.
                            "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

                            Comment


                            • #15
                              Re: cannot appy control panel policy

                              I found answer to my question about editing GPO securtiy
                              (where I can check uncheck rights)

                              Delegation tab --- Advanced button.

                              Thanks for advices. I experimented, read and have understanding. Now it's easier to work.
                              Sorry for my panicing questions.
                              Last edited by mla; 18th October 2008, 02:31.
                              "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

                              Comment

                              Working...
                              X