No announcement yet.

GPO Published Applications problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • GPO Published Applications problem

    I have a fairly large list of published applications that are available via group policy. I recently changed the target source location for all the msi packages to the DFS location by using ADSI. Everything is working fine from client machines, policy is applied and users are able to install software from the new location. I do need to mention that the old target source was on a DC, lets call it Server1 (\\Server1\installers). New target location is \\domainname\installers.
    Couple days ago I replaced Server1 with a new machine. I went thru the demotion/promotion, etc. The new machine is also called Server1. It is also a DC. However, when I tried to install an application from the published list, I got an error that network resource is unavailable and the path it tries to use to locate the msi is \\Server1\installers. Now RSOP shows the policy is correctly applied to the DC and I am not having this issue with 2 other DCs on my network. I cannot understand how this newly installed DC even got the old target path.
    If anyone has any ideas, please let me know. Thanks!

    P.S. Upon further research I noticed that this problem is not isolated to only the DC, some of the workstations are still trying to locate the msi files in the old target path. RSOP shows the policy applied on these machines, so I am still stumped.
    Last edited by jrtechie10; 20th May 2008, 20:30.

  • #2
    Re: GPO Published Applications problem

    Is there nobody that can even point me where to look for the solution?


    • #3
      Re: GPO Published Applications problem

      I think that what happened is this:
      - you manually edited the GPO
      - GPO version number has not been increased
      - Clients that had the GPO applied before the change are using the cached version of the GPO because there is no change in the version number

      What happens if you join a new machine to the domain? Does it try to go to the old location?
      Guy Teverovsky
      "Smith & Wesson - the original point and click interface"


      • #4
        Re: GPO Published Applications problem

        guyt, I think you are correct. When I join a new machine it does try to go to the old location. What do I need to do to change the version number?


        • #5
          Re: GPO Published Applications problem

          Could you please explain how to change the version number manually?? This problem is really quite annoying.


          • #6
            Re: GPO Published Applications problem

            You havent mentioned anything concerning gpupdate so I am wondering if you have run gpupdate /force on your clients as this should force them to refresh their policies even if it is the same version.

            Alternatively if you don't want to have to do this on random machines that decide not to work you could set a policy on your network to force all clients to update the security policy even if it hasn't changed. Although this may have an effect of increasing bandwidth you may be able to take it off after a few weeks without it breaking again.

            On a GPO that applies to all client computers goto..

            Computer Configuration...Administrative Templates....System....Group Policy.. Security Policy Processing.

            On this policy there are two options

            Process even if the Group Policy Objects have not changed and
            Do not apply during periodic background processing.

            I would select them both for a while then turn of the second one mentioned above make sure everything works say after a week and then you may be able to turn them both off although if you don't notice any negative effects I wouldn't bother.

            Hope this helps.


            • #7
              Re: GPO Published Applications problem

              Thanks for your post, however the problem is that the GPO is applied to users not computers so as per your suggestion "On a GPO that applies to all client computers goto..", this would not work.

              Also, I did not see these options when editing GPO

              "Process even if the Group Policy Objects have not changed and
              Do not apply during periodic background processing."

              I did the gpupdate several times on different clients but still have the problem. Also, I did increase the version number manually, but to no avail.

              Any other suggestions??


              • #8
                Re: GPO Published Applications problem

                If my memory is correct although this is applied in the computers section of the policy it will also ensure that the user policies are re-enforced or applied at every reboot. Using this method should elimante a policy refresh problem and indicate a replication or actual policy error (e.g. two conflicting policies being applied at the same time). Anyway it was just an idea, you may be right and it wouldn't help at all.

                However there is also a setting for software installation policy processing so it may be a better idea to force that policy to be updated even if they haven't changed for that but that may slow your startup process as it always checks for changes even if they haven't occurred depending on how you have it set up

                Sorry if that doesn't help


                P.S. are you running a windows server 2003 domain, because i actually looked up their correct names on the 2k3 domain I am working on at the moment so I am quite confident that they should be there. Maybe i wasn't as clear as i could have been the last item (Security Policy Processing) is an actual setting not a folder and the two options mentioned are checkboxes within that setting.
                Last edited by danny_kay1710; 6th June 2008, 21:18.


                • #9
                  Re: GPO Published Applications problem

                  Well, I tried all the suggested fixes (including manually incrementing the GPO version) but still have the same issue. When trying to install a published app, it tries to go to the old server location. I am stumped and incredibly frustrated. I am thinking of just deleting the GPO and recreating it from scratch.


                  • #10
                    Re: GPO Published Applications problem

                    Can you post a screenshot of the GPO Settings report please. as well as the userenv logs for one of the clients that still point to the old server.
                    Technology is only as good as those who use it

                    My tech blog -