Announcement

Collapse
No announcement yet.

Folder Redirection not redirecting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Folder Redirection not redirecting

    Here is a brief overview of my setup:

    The server is running windows server 2003 and is setup as a domain controller.
    The client pc is running WinXP pro sp2 and is a member of the domain.
    The two are networked together using a linksys 4 port router.

    I can log into the domain from the client and my group policy settings (such as remove the recycle bin from the desktop) are being applied. However, I can't get the basic folder redirection to work which is part of that same group policy.

    I point the folder redirection to \\server\users\ and I want each user that logs into the client pc to have the my docs folder redirected to \\server\users\%username%. My question is, what do the security settings on the "users" folder need to be set for? Do I need to manually create each of the users folders or is redirection supposed to do this for me? Does the "users" folder also need to be "shared on the network"? And are there any other settings in the domain security policy or anywhere that need to be configured to allow this to happen? Thanks!

  • #2
    Re: Folder Redirection not redirecting

    Here's how we do it:

    Setup the users' profiles on the fileserver (this is the AD profile folder for all domain users):

    H:\Profiles

    This folder is shared as "Profile$", has "Everyone" with "Change" & "Read" permissions on the share with security set to Domain Admins with "Full Access" and Domain Users with "List Folder/Read Data" and "Create Folders/Append Data". This should be pretty much standard.

    You would have all your users' profiles as sub folders.

    In a GPO, create the following settings:
    User Configuration (Enabled)
    Windows Settings
    ....Folder Redirection
    ........Application Data
    ............Setting: Basic (Redirect everyone's folder to the same location)
    ................Path: %USERPROFILE%\Application Data
    ............Options
    ................Grant user exclusive rights to Application Data Disabled
    ................Move the contents of Application Data to the new location Enabled
    ................Policy Removal Behavior Restore contents

    My Documents
    ....Setting: Advanced (Specify locations for various user groups)
    ........Group Path
    ............SCL\gGpl_HomeServer_MyServerSite1-SRV \\MyServerSite1-SRV\Redirected$\%USERNAME%\My Documents

    Options
    ....Grant user exclusive rights to My Documents Disabled
    ....Move the contents of My Documents to the new location Enabled
    ....Policy Removal Behavior Leave contents
    Note we use AD groups to assign users the server which we want to house their profile as we have multiple sites.

    Hope this helps.
    |
    +-- JDMils
    |
    +-- Regional Systems Engineer, DotNet programmer & Jack of all trades
    |

    Comment


    • #3
      Re: Folder Redirection not redirecting

      Also make sure that Terminal Services is not running on that server. We had an issue in our company with folder redirection and after analyzing the event log we found out from MS that we can't have TS running on that server.
      cheers

      Comment


      • #4
        Re: Folder Redirection not redirecting

        Ok it is kind of working. I set it up as you suggested and the folders are being created on the server (\\server\profiles$\%username%\my documents) but the my docs folder is not redirecting on the client. When i run rsop.msc I see the error exclamation on the user settings part.

        What does the $ sign do on the end of the folder when sharing it?

        I am able to navigate (thru start >> run) on the client to \\server\profiles$ and get into my folder, but i get an access denied when trying to create a new document in it.

        And, i had the folders redirecting once before (not sure how and i cant do it again) but they had the folder synchronization icon on them. How do I turn that option off to not make them available offline?

        Comment


        • #5
          Re: Folder Redirection not redirecting

          The $ sign hides the share so that nobody can see it while browsing the network. It sounds like you have a permission problem on the folders.


          Take a look at the following article:

          http://technet2.microsoft.com/window....mspx?mfr=true

          Make sure you look at the Security and Best Practices sections as well.

          Comment


          • #6
            Re: Folder Redirection not redirecting

            I am able to navigate (thru start >> run) on the client to \\server\profiles$ and get into my folder, but i get an access denied when trying to create a new document in it.
            joeqwerty is right here. You need to setup the correct security on the folders and make sure the security propagates down the relevant folder tree.
            And, i had the folders redirecting once before (not sure how and i cant do it again) but they had the folder synchronization icon on them. How do I turn that option off to not make them available offline?
            You can do this manually. Right-click My Documents, click Properties. Now click the Move button. Select a root folder on the server share and voila! Our workstations use the Windows Synchronise function to sync the folders to the workstations (this runs when the users log off).

            To restore the folders back (manually), you need to "move" the My Documents to the local machine.

            But I'm sure with the brilliant article from joeqwerty you should be right to do this automatically. Oh, I'll contribute with this one....have you read This post?
            And this one MS TechNet User Profiles and Folder Redirection FAQ?

            My friend Biggles would quote this site......Don't be scared of the nasty man....click it!
            Last edited by JDMils; 18th October 2007, 12:52.
            |
            +-- JDMils
            |
            +-- Regional Systems Engineer, DotNet programmer & Jack of all trades
            |

            Comment


            • #7
              Re: Folder Redirection not redirecting

              Check under the group policy folder redirection settings that it hasent granted user exclusive rights.

              Comment

              Working...
              X