No announcement yet.

SNMP Community via GPO

  • Filter
  • Time
  • Show
Clear All
new posts

  • SNMP Community via GPO

    Hi all,
    Does anyone know how, through Group Policies, I can set a Read/Write community string. A program that i use needs to have a Read/Write stringl. I for the life of me cannot figure out how to set this. When i set the community string via GPMC i get a Read Only community.

    I have searched the registry for this setting, and this is what I have found. When you put a SNMP community string it creates an entry in the registry at HKLM\System\CurrentControlSet\Services\SNMP\Parame ters\ValidCommunities.

    When you put in a Read Only Community, it creates the string in the registry with a Reg_Dword value of 4(Hex)/4(Decimal).

    When you put in a Read/Write community, it creates the string in the registry with a Reg_Dword value of 10(Hex)/16(Decimal).

    Now for the fun part, i set a Read/Write community string, before i applied the GPO, my program worked, and everything was great. Then, i applied the GPO, rebooted the system and the program stopped working. I checked the registry and the Reg_Dword was still set to 16, but it wasn't working. (Removing the GPO fixed it though!!!!!)

    I know i could just disable the GPO, but i have over 100 servers that i need to make this change to.

    I have searched Google, Microsoft, ExpertsExchange, and have come up with nothing.

    Any help would be greatly appreciated.

    Thanks much

    Last edited by apperrault; 19th September 2007, 05:38. Reason: I had a typo that totally mis-represented what i needed

  • #2
    Re: SNMP Community via GPO

    UTFSE and google gave me more than i care to know about GPO's and SNMP configurations...

    here is a cutom adm that might be applicable:
    its easier to beg forgiveness than ask permission.
    Give karma where karma is due...