Announcement

Collapse
No announcement yet.

Access to File Server by \\Server_Name instead of \\IP_Name.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Access to File Server by \\Server_Name instead of \\IP_Name.

    Hi!

    I had a trouble when config DNS server in VLAN as follows:

    My company have 3 VLAN A, B, C. File Server + DNS + AD placed in VLAN A, users in VLAN A can access your File Server by \ \ IP_Add Server or \ \ Server_name. But User B & C in VLAN can only access by \ \ IP_Add of Server and can not be accessed by \ \ Server_name.

    Could you shoe me how to configure the DNS Server? In order Users in VLAN B & C can access the File Server by server name not IP only?

    Many Thank!!!

  • #2
    Re: Access to File Server by \\Server_Name instead of \\IP_Name.

    check that DNS is routing between the vlans.
    can you communicate with DNS in VLAN1 from VLAN2/3 ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Access to File Server by \\Server_Name instead of \\IP_Name.

      Can a user in vlan B run this command:
      nslookup Server_name
      The results should show the full dns name and the ip address of one of the internal dns servers. And next it shows the full dns name (hostname.domain.local) and the correct ip address of Server_name. Is that correct?


      /Rems

      This posting is provided "AS IS" with no warranties, and confers no rights.

      __________________

      ** Remember to give credit where credit's due **
      and leave Reputation Points for meaningful posts

      Comment


      • #4
        Re: Access to File Server by \\Server_Name instead of \\IP_Name.

        Are you using the FQDN of the server or just the name? i.e

        server1.mydomain.local or server1?

        If the first then DNS is the issue. If the second then WINS is the issue.

        Comment


        • #5
          Re: Access to File Server by \\Server_Name instead of \\IP_Name.

          Thank you for your support!

          - when I "nslookup servername" the result is:

          C:\Users\bkadmin.PC>nslookup filesrv
          Server: filesrv.ztec.local
          Address: 192.168.1.1

          *** filesrv.ztec.local can't find filesrv: Server failed

          - Users at VLAN B & C can access to file server by FQDN \\filesrv.ztec.local

          My expect is \\servername only.

          Please continue kindly help!
          Thank you very much.

          Comment


          • #6
            Re: Access to File Server by \\Server_Name instead of \\IP_Name.

            you need a DNS search suffix.
            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

            Comment


            • #7
              Re: Access to File Server by \\Server_Name instead of \\IP_Name.

              or a WINS server.

              Comment


              • #8
                Re: Access to File Server by \\Server_Name instead of \\IP_Name.

                Originally posted by tehcamel View Post
                you need a DNS search suffix.
                Thank so much for your reply.

                I had no experience about DNS suffix so could you please give me more info about that.

                Thanks!

                Comment


                • #9
                  Re: Access to File Server by \\Server_Name instead of \\IP_Name.

                  Originally posted by halq View Post
                  Thank so much for your reply.

                  I had no experience about DNS suffix so could you please give me more info about that.

                  Thanks!
                  Configure your DHCP scope, I assume your using DHCP, and add a DNS suffix.

                  Should be option 119.

                  Comment


                  • #10
                    Re: Access to File Server by \\Server_Name instead of \\IP_Name.

                    Originally posted by wullieb1 View Post
                    Configure your DHCP scope, I assume your using DHCP, and add a DNS suffix.

                    Should be option 119.
                    Thank you very much for your support!

                    I already solved this issue by your direction DHCP+DNS suffix attribute.

                    Thank you!

                    Comment

                    Working...
                    X