Announcement

Collapse
No announcement yet.

wrong IP to internet but correct website!?!?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • wrong IP to internet but correct website!?!?

    We have two DNS servers inside pointing to our firewall that uses a couple OPENDNS servers. When I ping this website (and this issue is ONLY with one website)

    Ping www.website.com I get the wrong IP address (I know because it's mine)
    website.com I get the correct IP (no www)
    When I surf to www.website.com it views just fine
    I check our domain name manager and "www" is pointing to the @ (root) which is website.com, as expected.

    This issue is only internal to our organization...pinging from home returns the correct results. So something with internal DNS is screwy! NSLOOKUP returns the wrong value.

    There are no manual entries for this site in our DNS.

    Not...we cannot figure out this same issue with any other site other then our one site. I've done IPCONFIG/FLUSH, restarted the DNS serves, tried different OPENDNS server values in the gateway...you name it.

    What do I do next to figure this out.

    PS. The only reason we figured this out was that our monitoring software that pings the website started returning "offline" values but when we would surf to the site, it was up and running just fine.

  • #2
    Re: wrong IP to internet but correct website!?!?

    Whats the bets your domain name and website name are the same???

    If it is then please add an 'A' record entry for www and point it to your external address.

    Comment


    • #3
      Re: wrong IP to internet but correct website!?!?

      Originally posted by wullieb1 View Post
      Whats the bets your domain name and website name are the same???

      If it is then please add an 'A' record entry for www and point it to your external address.
      Nope, but an good guess.

      Our domain is snowtr.local and the domain in question is snowtrails.org. Although the snowtrails.org is hosted on a server at our facility is is NOT on this domain...it shares the same ISP router.

      As far as I know everything has been working about two years until yesterday. My only thought is if the resolution to the wrong IP was always there...then the monitoring software I use has always been pinging the wrong IP...and just recently that wrong IP (somewhere in Colorado) just went offline...thus to trigger it. The wrong IP in question is 198.66.195.23

      I doubt all of that. Again the bizarre thing is there are no special records in the DNS I've created for the snowtrails.org and we can surf to the site just fine, but pings, tracerts, ect return the wrong IP.

      Comment


      • #4
        Re: wrong IP to internet but correct website!?!?

        Ok. Now if i had that information in the first place i could have better answered the question.

        Now onto your problem.

        I have an ip address of 70.60.51.162 as your external address. Is this correct??

        I presume you have cleared your DNS cache on the affected machine?? ipconfig /flushdns

        Have you changed any firewalls or NAT policies recently??

        You could depending on your setup, and seeing as you own the domain, a forward lookup zone on your DNS server and add the relevant addresses to it. This should clear problems in the future.

        Comment


        • #5
          Re: wrong IP to internet but correct website!?!?

          1. That is the correct IP for the domain in question.2
          2. No changes on NAT or Firewall
          3. Yes on DNS Flush
          4. I am aware that I can make changes on my DNS servers by creating a zone and assigning the correct IP to the www

          Sorry I didn't give the details the first time but it really hasn't gave anymore light to the concern in the sense that we know what this occurred...I know how to fix it, I"m more concerned why it happened...as it could be the symptom of a great concern, correct?

          Comment


          • #6
            Re: wrong IP to internet but correct website!?!?

            Have you flushed the DNS cache on your DNS server??

            Comment


            • #7
              Re: wrong IP to internet but correct website!?!?

              Originally posted by wullieb1 View Post
              Have you flushed the DNS cache on your DNS server??
              I believe I did...but I just went into doublecheck now and redo. While there I just tested the "www" ping again, and of course it's working.

              I'll continue to monitor this concern and report back, thanks for your help if I'm not back on here soon complaining again.

              Comment


              • #8
                Re: wrong IP to internet but correct website!?!?

                Did you test before or after the flush??

                After would mean that your DNS server has probably received the wrong information at some point, probably after a reboot and the cache was flushed, and is passing that on to your clients.

                Seen this happen many times before.

                Comment


                • #9
                  Re: wrong IP to internet but correct website!?!?

                  I tested before I "flushed" and the IP address was correct now. I then "flushed" again...and I know I rebooted both DNS servers during the course of our discussion.

                  Comment

                  Working...
                  X