No announcement yet.

Some web sites not resolving...

  • Filter
  • Time
  • Show
Clear All
new posts

  • Some web sites not resolving...

    Hi, folks

    Can anyone help me understand a DNS issue resolving external web sites, please?

    We have a Windows Active Directory domain. Two DCs, one W2k3 and the other W2k8. All FSMO roles are on the W2k8 DC. DNS on both, active directory integrated, both have static addresses.

    Clients get their IP details via a DHCP scope from the W2k3 DC. DHCP scope options include DNS servers, WINS, gateway etc.

    Our Internet connection is via a router. IP configuration is as follows:

    Static address, points to itself for DNS, gateway is the IP address of the router.

    DHCP address, both DC's listed in scope options for DNS servers, same gateway address.

    This has worked wonderfully for many years.

    This week the W2k3 DC suffered a major hardware failure and has gone to server heaven until I can resurrect it with a new RAID card.

    I setup DHCP on the W2k8 server using the same scope configuration and options, but included only the remaining DNS server.

    Clients are getting their addresses fine and roles transferred from the W2k3 to the W2k8 - e.g. print server - are working fine too. The only role that has not been transferred is WINS, which failed to install on the W2k8 DC (I am going to try and sort that out this weekend).

    The problem we had was that certain web sites could not be resolved after the W2k3 DC went down. Two sites affected were and Virtually all other sites could be accessed without issue. I rebooted the router but the problem persisted.

    It was not until I restarted the W2k8 DC that the sites resolved and could be accessed. This was the first time the W2k8 DC had been restarted since the W2k3 DC failed.

    This weekend I will be carrying out a meta-data cleanup to remove all traces of the W2k3 server from the domain. As the meta-data cleanup has not been carried out yet, could this be a contributing factor to the lack of DNS resolution for some sites?

    However, I thought that if a web address could not be resolved by a DC, the request would be passed through the gateway and our ISP's DNS servers would be queried for the IP address of the site in question.

    I don't understand why just the two web sites failed to resolve until the W2k8 DC was rebooted.

    Any help with this, please?


    (This is where you reply and point out the blindingly obvious)
    A recent poll suggests that 6 out of 7 dwarfs are not happy

  • #2
    Re: Some web sites not resolving...

    have you tried resolving it with NSlookup?
    Technical Consultant

    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"


    • #3
      Re: Some web sites not resolving...

      No, I didn't. If it happens again (which is unlikely as the server is no longer a DC) in the future I'll remember to do that.

      A recent poll suggests that 6 out of 7 dwarfs are not happy


      • #4
        Re: Some web sites not resolving...

        It happened again today. I had removed the failed DC from the Domain Controllers folder in Active Directory Users and Computers by right-clicking the server (Titan) and choosing Delete. I had read that this would automatically trigger a metadata cleanup. I made sure that the option that asked if it was not possible to remove it via dcpromo was checked. This proceeded fine.

        Yesterday lots of staff were having problems accessing DFS shares. Rebooting would often sort this out, but I checked AD and found the failed server was still listed in Active Directory Sites and Services (ADSS).

        Today I removed the server by right-clicking Titan in ADSS and choosing Delete. As soon as I did the same problem occurred. No one could access or

        nslookup gave the following output:

        Microsoft Windows XP [Version 5.1.2600]
        (C) Copyright 1985-2001 Microsoft Corp.

        C:\Documents and Settings\blood>nslookup
        Server: phobos.htlincs.local

        *** phobos.htlincs.local can't find Server failed

        C:\Documents and Settings\blood>

        Phobos is the name of W2k8 DC. I restarted Phobos and the web sites could be accessed again.
        Last edited by Blood; 13th October 2011, 14:32.
        A recent poll suggests that 6 out of 7 dwarfs are not happy


        • #5
          Re: Some web sites not resolving...

          This happened again yesterday. This time nothing had changed. Same sites.

          I set up two forwarders that pointed to our ISP's DNS servers and the problem cleared up immediately.

          I've never had to use forwarders before so hope this solves the problem.
          A recent poll suggests that 6 out of 7 dwarfs are not happy


          • #6
            Re: Some web sites not resolving...

            I've found some occasions where 2008 dns for some reason just gets corrupt entries in it's resolver cache for external sites..

            maybe instead of rebooting, try cleaning the resolver cache on the server ?
            Please do show your appreciation to those who assist you by leaving Rep Point


            • #7
              Re: Some web sites not resolving...

              Thanks, tehcamel

              Luckily, I did not need to reboot after setting up the forwarders, it just worked

              If it should happen again (and I hope it does not), I will certainly try your suggestion.

              A recent poll suggests that 6 out of 7 dwarfs are not happy