Announcement

Collapse
No announcement yet.

Resolving Non-Domain DNS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Resolving Non-Domain DNS

    i have asked a similar question to this before, but at this point i am spent on research, trial and error. I've been trying to fix this since March,
    i would like to resolve a server NOT on the domain. i would like to type in the hostname/wordpress name and it take me to the website on the server, which would be the hostname/wordpress/admin, to the login page.

    i lookup up split dns, and came up with the below.


    On my domain server, i've added a primary forward lookupzone name test.test.org. and unchecked "Store the zone in active directory". I clicked next on "Create a file with this file name". Next was a box checked by default "do not allow dynamic updates", so i kept the same.

    When finished, i created a new Host A record with in the zone. I left the name blank to use the parent domain. I typed in the ip address.

    when i do a nslookup, it shows it resolves, but when i go to the web browser, type in the hostname/wordpress name, it doesn't load. if i type the ip address of the server, on a client computer, with the hostname under windows/system32/drivers/etc, it works. But deleted, it doesn't.

    On the client computer that i'm trying to access the hostname/wordpress name , i have the dns pointed to the dns server as the proffered dns server.

    Am i doing this all wrong, or a little wrong. Is this not possible



    Also, is there i way to find out what(internal server, external server) is resolving an address....tracert hostname?


    Thank you
    Last edited by Kobe 310; 5th June 2015, 19:54.

  • #2
    See this post for info on what's going on when you use just the hostname:
    https://www.petri.com/forums/forum/m...452#post490452

    To resolve your issue you have two options:
    1. Add a record to your domain's DNS of "hostname" pointing to the proper IP
    2. Create a separate DNS zone (like you did) and then add that zone's DNS suffix to every client. This can be done through group policy. Note that if the zone is "test.test.org" and the record you add is "same as parent", the DNS suffix should be "test.org".
    Regards,
    Jeremy

    Network Consultant/Engineer
    Baltimore - Washington area and beyond
    www.gma-cpa.com

    Comment


    • #3
      Thanks Jeremy!!! i scrolled through the forum, but couldn't find anything to help. thanks for finding that. I'll give it a try.

      Comment


      • #4
        i forgot that i've tried to add the hostname to the DNS suffix. i did a nslookup and it seems that the webserver is resolving now. Just not sure how, IIS 7? but working. I'm now trying to do it through a site to site vpn and not working. But adding to clients works.
        Last edited by Kobe 310; 8th June 2015, 15:08.

        Comment


        • #5
          Originally posted by Kobe 310 View Post
          i forgot that i've tried to add the hostname to the DNS suffix.
          That won't work. Let's say the hostname is "testsrv". If you add testsrv to the DNS suffix list, when you try entering testsrv to connect to the server your computer will attempt to resolve "testsrv.testsrv" (as well as every other DNS suffix you have). That's why you need to either add the record to your existing zone or create a new zone and add the suffix to the computers.The easiest would be to add it to your existing zone.

          Originally posted by Kobe 310 View Post
          i did a nslookup and it seems that the webserver is resolving now. Just not sure how, IIS 7?
          IIS does not resolve resources. This is a function of DNS or NetBIOS. If it's on the same subnet then it's most likely NetBIOS. This would explain why the VPN resolution isn't working.
          Regards,
          Jeremy

          Network Consultant/Engineer
          Baltimore - Washington area and beyond
          www.gma-cpa.com

          Comment


          • #6
            thanks Jeremy,

            so on my vpn side when i do a nslookup to the webserver by ip address from the client computer and it comes back showing below

            serverdnshostname).(domain name(assuming that is the suffix)).com.........BEING CORRECT
            address:dnshostname(domain server) ip address....BEING CORRECT

            name:webserver host name.....being correct
            address:webserver ip address...being correct

            and it doesn't resolve, like it does on the same subnet, that's were i'm confused. It showes that it's resolviing the webserver host name on the vpn side, but not pulling up the webpage.


            Comment


            • #7
              When you lookup by IP you are performing a different query. It will return a PTR record which is in the in-addr.arpa zone (AKA reverse lookup zone). You need to add the record to your forward lookup zone.
              Regards,
              Jeremy

              Network Consultant/Engineer
              Baltimore - Washington area and beyond
              www.gma-cpa.com

              Comment


              • #8
                i had it in both. so i just deleted the record from the reverse zone (left it in the exsisting zone), and when i did the nslookup, it saw the dns server, but the name said [ip address/Non-existent domain].

                i then created a new zone, added the a record, went to client, added the dns suffix, now the dns suffix is recognized, still no go.

                Last edited by Kobe 310; 8th June 2015, 19:30.

                Comment


                • #9
                  i then created a new zone
                  What new zone?
                  Why did you need to create it when all you needed to do was add the A Record as per Jeremy's post.
                  1 1 was a racehorse.
                  2 2 was 1 2.
                  1 1 1 1 race 1 day,
                  2 2 1 1 2

                  Comment


                  • #10
                    How about some screenshots? There's obviously something we're missing since what you're trying to do isn't difficult to setup.
                    Regards,
                    Jeremy

                    Network Consultant/Engineer
                    Baltimore - Washington area and beyond
                    www.gma-cpa.com

                    Comment


                    • #11
                      I added the new zone for the 2nd option of he gave me at the top of this post if i understood it correctly. I then went to the client and added the suffix on the adapter.
                      Last edited by Kobe 310; 8th June 2015, 21:27.

                      Comment


                      • #12
                        So in your pics, is the FQDN "host.domain.org" or "domain.org"?
                        And are you really adding a same as parent record to the AD DNS zone that doesn't point to a Domain Controller? If so, delete it immediately!

                        Let me lay out a scenario and hopefully that will get you where you need to go.

                        1. You want to type in http://hostname in your browser and have it resolve to 1.1.1.1
                        2. You have an Active Directory and DNS domain called mydomain.com

                        To get this to work:
                        - In the DNS console, navigate to the mydomain.com zone
                        - Right click and add a new A record
                        - In the Host field type in hostname, in the IP addres field type in 1.1.1.1 and click OK.

                        You should now be able to go to http://hostname from any domain joined computer.
                        Why? Because mydomain.com is in the DNS suffix list of every domain joined computer.
                        Regards,
                        Jeremy

                        Network Consultant/Engineer
                        Baltimore - Washington area and beyond
                        www.gma-cpa.com

                        Comment


                        • #13
                          i scratched out names because last time i showed, i was advised not to show...sorry about that


                          it's host.domain.org
                          this is the domain controller...so not sure if i should still delete as you suggested

                          1. on the remote site, it says this webpage is not available. On the same network side, it shows the webpage IIS.
                          2 The active directory and the dns domain is on that sever that is scratched out. host.domain.org

                          I am using NON-Domain clients to try to connect to the webserver, which is a non-domain server.
                          Last edited by Kobe 310; 9th June 2015, 15:43.

                          Comment


                          • #14
                            ok, so i added the hostname to the host field on the dns server. i then joined the computer on the remote side to the domian, and everything works. But i would like this to work off the domain. if i have to put something on each compuer for it to work, that's good. I was hoping that i could use the dns server to resolve this issue without having to put something on each computer.

                            Thanks for your help. Not trying to be a pain in the butt, very confusing to me.
                            Last edited by Kobe 310; 9th June 2015, 16:03.

                            Comment


                            • #15
                              Originally posted by Kobe 310 View Post
                              i scratched out names because last time i showed, i was advised not to show...sorry about that
                              No problem. I just was wondering how many levels we're dealing with.

                              Originally posted by Kobe 310 View Post
                              it's host.domain.org
                              this is the domain controller...so not sure if i should still delete as you suggested
                              If that is a DC then the record is correct and don't delete it. But why did you post a picture of that? You said you wanted to resolve the hostname of a non-domain joined server and that you had setup a record for that.


                              Originally posted by Kobe 310 View Post
                              I am using NON-Domain clients to try to connect to the webserver, which is a non-domain server.
                              OK, this is different then. So none of these clients are joined to any domain? How many clients? If it's only a few then just add the server to the hosts file on each client. If it's a lot of clients, then why are they not in a domain?
                              Regards,
                              Jeremy

                              Network Consultant/Engineer
                              Baltimore - Washington area and beyond
                              www.gma-cpa.com

                              Comment

                              Working...
                              X