Announcement

Collapse
No announcement yet.

cannot find DHCP servers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot find DHCP servers

    Bit of an odd one this, we have a mixture of XP/Win7 and DHCP/Static workstation configs.

    All ICT have static but using dhcpfind, nothing is picked up. Put that to one side for the moment because that could be our vlan config on the switches.

    For DHCP, on an XP PC the same utility only finds our current master DC, but when I use another utility it finds our other DHCP server as rogue but then saw it as authenticated when I searched again (although I did authorise it via MS DHCP which reported it authorised already).

    On a Windows 7 PC using DHCP the dhcpfind doesn't find anything but it has a valid IP from the other DHCP Server.

    I'm on the verge of swirching off some old kit but with these results I'm thinking again.

    Any thoughts?

  • #2
    Re: cannot find DHCP servers

    Also tried the dhcploc program and it just sits there without returning any results

    Comment


    • #3
      Re: cannot find DHCP servers

      You mention VLAN's. Do you have the correct IPHELPER address on the switch??

      What happens if you plug in a machine to the same VLAN as the DHCP server??

      Please also be aware that when a client requests a DHCP address it broadcasts and will work with the first to answer.

      Comment


      • #4
        Re: cannot find DHCP servers

        Originally posted by wullieb1 View Post
        You mention VLAN's. Do you have the correct IPHELPER address on the switch??

        What happens if you plug in a machine to the same VLAN as the DHCP server??

        Please also be aware that when a client requests a DHCP address it broadcasts and will work with the first to answer.
        That's my thought, vlan config. Before we went this route I could run dhcpfind on any LAN PC and it would report back all active DHCP servers that were broadcasting.

        Now I get one result per PC although rouguechecker reports them all but I suspect that's interogating AD and not broadcast.

        Have to look into the config.

        Comment


        • #5
          Re: cannot find DHCP servers

          Bit more on this, I disabled the DHCP service on a Server one of the Domain PC's retrieves its settings from and the tool reported blank finds. I then released the IP and attempted renew and it got it's new settings from the other DHCP server.

          So the broadcast must be working ok

          Comment


          • #6
            Re: cannot find DHCP servers

            So you are actually getting IP addresses from the server then??

            It appears to me that DHCPFIND is a third party tool. For this reason i would be looking at using something like wireshark to capture your network traffic and analyse for the DHCP packets being sent from your client.

            Comment


            • #7
              Re: cannot find DHCP servers

              We do get an IP, but it seems to be random what DHCP server we get it from. Once done, DHCP find only reports finding said DHCP server which led me to think it could only receive a response from one of them.

              It's strange because DHCP used to report both and it doesn't any more. Although I'm configured with static settings because we use different vlan switches which doesn't always help with these issues.

              Comment


              • #8
                Re: cannot find DHCP servers

                Your DHCP requests get answered by the first DHCP server to respond.

                Comment


                • #9
                  Re: cannot find DHCP servers

                  Originally posted by wullieb1 View Post
                  Your DHCP requests get answered by the first DHCP server to respond.
                  That's what I'm aware of too but it's just strange that the tool I've always used to report active DCHP scopes only ever finds the one that the PC is using, not all of them as before.

                  Comment

                  Working...
                  X