No announcement yet.

DHCP not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP not working

    Ive just dcpromo'd my home server 2008 box to make it the first DC in my domain. I then installed DNS & DHCP. I have an ADSL modem acting as the gayeway connected to a wireless router which is connected to a switch. The DC is also connected to the switch.

    The plan is to have servers on 192.168.1.x & then everything else on 192.169.0.x

    The router & gateway are configured to connect to the DC on 192.168.1.x address. The servers are all talking to each other fine but when I try to connect with DHCP it looks like its not passing the request onto the DC. I can see the device On the wireless router but it doesn't connect.

    Does anyone have any suggestions about what it could be? I've checked the logs on the DC & router & there at no errors. I'm guessing it's a routing issue of some kind. I can access the Internet fine on the servers

  • #2
    Re: DHCP not working

    You mentioned separating some machines to the 192.169.x.x subnet. You should be aware that the range is not part of the private ip range and your network would require a router between two subnets to pass traffic between them, in any case.

    Also, with regard to dhcp, if you are going to run that service on your server, you should disable dhcp services on your router.

    Again, unless you have established multiple segments, you should keep all devices on the same subnet.
    JM @ IT Training & Consulting


    • #3
      Re: DHCP not working

      Ok, do I ditched the 192.168.0.x range for now & suick with 192.168.1.x for everything.

      I set a new DHCP scope up as from - 200 & deleted teh old scope

      I also plugged my gateway router straight into the switch as it was plugged into the WAN port on my wireless modem (Wan port was acting a LAN)

      I checked I had DHCP switched off both the gateway & the wireless rourter

      Ive restarted everything.

      Im still getting the same result, the network still isnt passing the DPCP requests onto the server


      • #4
        Re: DHCP not working

        I worked it out, the gateway router was still issuing DHCP even though I have disabled it. I had to change the range, re-enable & disable for it to turn off.

        I also had a wireless filter enabled on the wireless router blocking any wireless clients which werenít on my allowed list.

        and finally I hadnít enabled the new DHCP range (school boy error)

        So its now working.

        Thanks for the advice on the IP range


        • #5
          Re: DHCP not working

          Ok, not a problem. Glad you resolved it!
          JM @ IT Training & Consulting