Announcement

Collapse
No announcement yet.

DHCP doesn't work for Linux server ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP doesn't work for Linux server ?

    Hi Everyone,

    If the DNS name is not properly registered to the DNS server through DHCP server for linux machine, which fault is this ?

    from the DHCP console it is blank with no hostname ?

    If anyone know how to fix this, that be great.

    Cheers,

    Albert
    Attached Files

  • #2
    Re: DHCP doesn't work for Linux server ?

    There is an option in DHCP to register leases in DNS, either all the time or when the client cannot do so itself.

    What OS is the DHCP server on?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: DHCP doesn't work for Linux server ?

      Originally posted by Albertwt View Post
      Hi Everyone,

      If the DNS name is not properly registered to the DNS server through DHCP server for linux machine, which fault is this ?

      from the DHCP console it is blank with no hostname ?

      If anyone know how to fix this, that be great.

      Cheers,

      Albert
      Thats expected behavior. Its a linux box and cannot dynamically register in DNS because it cant be added to the domain. Create an A record for it manually on your DNS server.

      Comment


      • #4
        Re: DHCP doesn't work for Linux server ?

        Surely the DHCP server can register the record "on behalf of"?
        Don't know about Linux but this was standard behaviour with legacy Windows systems
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: DHCP doesn't work for Linux server ?

          it can I think, but you need to allow unsecure registrations, or you need to create a specfic account that has authority to register.
          Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

          Comment


          • #6
            Re: DHCP doesn't work for Linux server ?

            Originally posted by Ossian View Post
            Surely the DHCP server can register the record "on behalf of"?
            Don't know about Linux but this was standard behaviour with legacy Windows systems
            For Windows legacy systems of course like NT4. But not for Linux. You must create the A record manually.

            Comment


            • #7
              Re: DHCP doesn't work for Linux server ?

              Nope, static DNS entries aren't needed, however there is one more option which needs to be configured on the dns zone: Dynamic Updates: allow both secure and unsecure
              Marcel
              Technical Consultant
              Netherlands
              http://www.phetios.com
              http://blog.nessus.nl

              MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
              "No matter how secure, there is always the human factor."

              "Enjoy life today, tomorrow may never come."
              "If you're going through hell, keep going. ~Winston Churchill"

              Comment


              • #8
                Re: DHCP doesn't work for Linux server ?

                IMHO if it was only a couple of machines i would leave the zone secure and manually add them (and do a dhcp reservation or change to static ip)

                Comment

                Working...
                X