Announcement

Collapse
No announcement yet.

Clients can't route to the internet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Clients can't route to the internet

    I must miss something silly.

    A Domain Controller with DHCP and DNS enabled has two networks.

    One network is the external network with access to the internet.
    One network is an internet network which assigns IPs via DHCP

    Now a client (in this case a linux client) gets the internal IP just fine but cannot route to the internet. It does have access to the DNS and DHCP server just fine, it can even resolve DNS just fine using nslookup but it just cannot route traffic ..

    I am not sure where to look to be honest. I have set option 003, 5, 6 and even 121 but I am seriously lost atm
    Last edited by Gomjaba; 1st October 2010, 11:22.

  • #2
    Re: Clients can't route to the internet

    Is it picking up a default gateway?
    (can you post the linux equivalent of an IPCONFIG/ALL please?)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Clients can't route to the internet

      It is picking up the default gateway but I think 2008 doesn't support routing out of the box .. I think I actually need to enable routing first on the DHCP server before it can actually route traffic from one network to another ..

      Comment


      • #4
        Re: Clients can't route to the internet

        Yes, you do need to enable routing in the RRAS role
        I misread your original post and thought it was only one client affected.
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Clients can't route to the internet

          I'm stuck on the same probelm

          i have two nics

          one connected to my router picking up an ip of 192.168.1.14, the other i have set to static of 192.168.0.1 sub 255.255.255.0 and no default gateway.and plug into a switch.

          i have installed Dhcp on windows 2008 server enterprize, which is given out an ip of 192.168.0.5 sub 255.255.255.0 but no default gateway is show even when i configured it to 192.168.0.1.

          I can view shared folder's , make a pc part of the domain but just can't for the life of me to get the internet going.

          So my question is?

          which nics needs to be static, most of the internet HELP doesn't tell you how to setup the nic's but it shows you how to setup the dhcp, how does the second nic get internet connection once you have dhcp enabled?

          I would be greatful if someone could explain it in simple terms.. how to assign a static ip and receive internet connection to clients once dhcp has been enable.


          cheer

          wingovo
          Last edited by wingovo; 23rd January 2011, 00:14.

          Comment


          • #6
            Re: Clients can't route to the internet

            Hi folks i've got it working

            After many hours with the same problem answer I FINNALY GOT The answer
            1. give both network cards static IP address.
            Nic one you will need to write down the ip address given by your router and then configure it as static. like so, 192.168.1.15 sub 255.255.255.0 gateway 192.168.1.1 leave the DNS blank.
            ( Nic two is the connection your internal network. configure it as static with an IP address of 192.168.0.1 and sub 255.255.255.0 leave both DNS and gateway blank
            Next
            go to server manager ...add role ...install and configure DHCP, as normal it will ask you to choose the nic which will be serving ip address..choose nic 2 ip address of 192.168.0.1
            next
            configure your scope .
            name it default
            start ip range as
            192.168.0.2
            End
            192.168.0.254
            Sub
            255.255.255.0
            Leave the gateway blank , finish the in stallion and reboot the server.
            After reboot your client pc should have and ip address but no internet access. THIS were problem starts, and after goggling and reading a number topics the logic is as followed and is right there in front of you.
            Go back to server management .....add roles ...install routing and remote access. One installed head to administrator tools and choose routing and remote access.
            Right click on your server a choose configure and enable routing and remote access...
            Now you want to choose NAT (allow clients to connect to the internet using one public ip)
            Click next, choose the network card that is connected to the internet (nic 1)....hit Finnish and reboot the server.
            Once reboot is done , login to the server physical and not remotely, stop the DHCP server. Unplug the switch for about 30 seconds, then restart the routing and remote ,plug the switch back in and you will notice that the client pc has lost the ip, now here come the best part, restart the DHCP server and unplug the switch for another 30 seconds , plug the switch in and run the command on the client pc ipconfig /release ...ipconfig /renew and now you should have access to both the network and the internet,

            This worked from me so if you have any problemís please report back here.

            Cheers
            WinGovo

            Comment

            Working...
            X