No announcement yet.

DHCP stopped 2008 Server Standard

  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP stopped 2008 Server Standard

    I will point out the obvious problem first and explain a lil how i got there and what I've done last. When you go into DHCP got to add/remove bindings the list is empty and says to verify that its static which it is a static IP

    Now how I got there... We had a shutdown issue it would restart instead of shutting down found there was an updated NIC driver that corrected this problem. After updating the driver, the system would attempt to get an IP address from another DHCP server getting a 169.254.x.x. I opened up the properties and it was still set to be a static of I then changed it to a known available IP, "ipconfig" showed the new IP but the properties of the connection showed yet. So I then changed it to DHCP and got the expected 169.254.x.x . Changed it back to and it shows that in the configuration and with "ipconfig". DNS and AD is working fine with the address changes but DHCP was not. I then tried restarting the service/server with no results. I have ran “ipconfig /flushdns”, “ipconfig /registerdns”, and “dcdiag /fix”. Removed DHCP and reinstalled DHCP role with no luck. The service appears to be running and no error logs, but there won't be if it has no bindings..... I have found a few post on this but they all end with another DHCP server..... It seems as there should be a solution to this any help is appreciated.

  • #2
    Re: DHCP stopped 2008 Server Standard

    Are you assigning a Dynamic IP to a Server?
    What NIC is the 169.254.x.x. IP being assigned. This IP range usually shows up when the NIC does not have a connection with the DHCP Server.
    What role does this Server have? A DC or a Member Server?
    Joined: 23rd December 2003
    Departed: 23rd December 2015


    • #3
      Re: DHCP stopped 2008 Server Standard

      I have had a simlar problem and it come down to a incorrect DNS entry, a pointer with my DHCP's name and a incorrect IP. Most services worked, yet meny others did not, and no errors.

      Also, have you uninstalled the NIC and reinstalled? All these problems started when you upgraded it, maybe the upgrade corrupted one of the settings?

      What IP are workstations attached to this servr getting? a 192.168 or a 169.254?

      If in asking for more details about a problem I seem to be rude, think about it this way, If I did not have to ask, I would not of been forced to be rude.

      Please assume anything and everything I say to be wrong unless I have provided links and evidence, or you have done the same.
      IE: you blow your server up following my advice, not my bad

      A OP is bad if I can go to and answer the question by pressing 4 buttons. "Ctrl +c, Ctrl +v".