Announcement

Collapse
No announcement yet.

cannot get IP from DHCP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot get IP from DHCP

    Hi ,
    I am working on site with ~ 400 PCs. Lately (2-3 days), many of them lost connection to network and cannot get IP from DHCP (169.254.XXX.XXX). System restore mostly solves the problem, but I have to find the point where it comes from.
    What was already tried:
    * uninstall, install, disable, enable NIC
    * check all processes on PC
    * reset TCP/IP and delete arpcache (netsh)
    * flushdns (ipconfig)
    * reset scope on DHCP, restart DHCP
    * restart all network line - computer-switch-...-router

    Setting static IP also solves the problem, but it is off course unacceptable one.
    All workstations are XP (sp.2 or sp.3).

    Anybody ?

    Thanks

  • #2
    Re: cannot get IP from DHCP

    So little information.
    Is this a Domain or a very large Workgroup?
    Do you have a DHCP Server installed on the Domain?
    What Server is DHCP installed on?
    Is the DHCP Server (application) still Authorised or has it gone Unauthorised (offline)?
    What messages are dispalyed in the Even Viewer?
    What Subnet mask are you using (you may have run out of IPs)
    169.254.x.x is an Automatic Private IP Addressing (APIPA) that is built into XP and is assigned by XP when it cannot find a DHCP Server.
    Check the Patch Lead between the DHCP Server, Server and the Switch.
    Check all Switch to Switch connections.

    Check than and if still not working post back with more info. Remember we can only learn about your network and its' configuration by what YOU tell us. You know and can see it, we can't.
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

    Comment


    • #3
      Re: cannot get IP from DHCP

      OK, little bit more:
      All computers are part of one OU. DHCP server is W2K3 and is authorized.
      IP pool has still long way to go and I cannot see anything useful for this particular problem,in event viewer .
      I checked several computers since and seems to me (at the moment) that problem is caused by Mcafee AV and not networking at all.
      Nonetheless still no solution.

      Thanks

      Comment


      • #4
        Re: cannot get IP from DHCP

        have you tried giving a client a static IP ?
        It might also be a switch problem..

        Comment


        • #5
          Re: cannot get IP from DHCP

          Is there any network fault preventing the DHCP server from seeing the rest of the network (can you ping it OK, is its firewall open for DHCP?)
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment


          • #6
            Re: cannot get IP from DHCP

            DHCP and network work correctly. I tried to install new computer and all ran just fine. Problem is, I am almost absolutely sure, in computer , but there i've done, as far as I know, everything to repair networking and ..... nothing.
            And yes, static IP solves the problem but it cannot be used as the solution

            Comment


            • #7
              Re: cannot get IP from DHCP

              Originally posted by peterko
              OK, little bit more:
              This is like pullin teeth. (I sort of wasted my time typing up all those questions I asked)
              Originally posted by peterko
              I checked several computers since and seems to me (at the moment) that problem is caused by Mcafee AV and not networking at all.
              Anything in the Event Viewer on the WORKSTATIONS??
              Last edited by biggles77; 24th March 2010, 19:00.
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment


              • #8
                Re: cannot get IP from DHCP

                First question is what has changed on the clients recently??

                Any updates been installed??

                Any firewalls enabled??

                Any security packages updated??

                Comment


                • #9
                  Re: cannot get IP from DHCP

                  Just to close the thread - still don't know what was the cause of the problem, but all network was hard reset, DHCP unauthorized and again authorized... problem solved.

                  Thanks to all of you for your help.

                  Comment


                  • #10
                    Re: cannot get IP from DHCP

                    Sorry, but problem not solved. It has just been fixed (and there is a difference).

                    Do you have anyone connecting to the Domain that may have a DHCP device on there machine?
                    Is there a Wireless Device or a seldom used Router that may get used infrequently?

                    Had a 50 PC factory that had a Router that was mostly kept off but was turned on whenever the need to infrequently access a specific piece of hardware. The Router (with DHCP enabled) was used as a switch to connect to the specific hardware. Made life extremely interesting because they run a Terminal Server inside the business. Only 1 person knew about this router and he thought it was a switch so it couldn't be the problem therfore nobody (me) was told about it. Took over 3 hours to isolate it.
                    1 1 was a racehorse.
                    2 2 was 1 2.
                    1 1 1 1 race 1 day,
                    2 2 1 1 2

                    Comment


                    • #11
                      Re: cannot get IP from DHCP

                      No concurrent DHCP, or anything simmilar on the network.This was one of the first things to check.

                      I spoke to "Cisco man", and he told me, that he saw something like this before caused by Catalyst and it is pitty I haven't call him before the restart, so he (maybe) could locate the root of the trouble.
                      Nonetheless solved or fixed matters little to me, at the moment, as far as it works ... end of quarterly = lot of pressure...

                      Thanks again for your help

                      Comment

                      Working...
                      X