Announcement

Collapse
No announcement yet.

DCPromo fails after removing Active Directory

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DCPromo fails after removing Active Directory

    We have 6 servers connected over a WAN running W2003.
    I installed a new server at one of our sites and successfully promoted the server.
    I then removed the old domain controller from the site.
    This caused a problem because my new DC could no longer contact the rest of the network.
    I used ntdsutil to remove the old server objects from AD.
    I then forced removal of AD from the new server and rejoined it to the domain.

    My problem is that I cant promote the new sever to a DC.
    The error from the dcpromo log is as follows:

    02/14 18:20:43 [INFO] Error - Active Directory could not replicate the directory partition CN=Schema,CN=Configuration,DC=mydomain,DC=com,DC=a u from the remote domain controller xxxx.mydomain.com.au. (181
    02/14 18:20:46 [INFO] NtdsInstall for mydomain.com.au returned 1818
    02/14 18:20:46 [INFO] DsRolepInstallDs returned 1818
    02/14 18:20:46 [ERROR] Failed to install to Directory Service (181

    When I look under NTDS settings for the site it lists the server as invalid.

    Any help would be greatly appreciated.

    Regards
    PeterC
    Best Regards

    Peter C
    MCSE

  • #2
    Re: DCPromo fails after removing Active Directory

    You might have to rebuild the server

    Comment


    • #3
      Re: DCPromo fails after removing Active Directory

      I am trying to avoid a rebuild if I can. The server is in Adelaide and I am in Perth. My boss wont be too happy if he has to send me to Adelaide again.
      Best Regards

      Peter C
      MCSE

      Comment


      • #4
        Re: DCPromo fails after removing Active Directory

        Is the DC in SA have a different subnet? if yes, try to change it to have the same subnet as WA. And then try running dcpromo else you will have to rebuild it.

        Comment


        • #5
          Re: DCPromo fails after removing Active Directory

          Can U Please Check DCPRMO.LOG file in Windows Directory to see which Server it is pointing for Replication. Personally i don't think you don't need to rebuild the Server as its not a AD Server.

          Comment


          • #6
            Re: DCPromo fails after removing Active Directory

            Thanks for the help.

            I have solved the problem by creating another site for the subnet and pointing the machine to a DC in another site by changing the DNS to point to the server in that site.
            For some reason it didnt like replicating from the PDC emulator but I dont know why.
            Best Regards

            Peter C
            MCSE

            Comment

            Working...
            X