No announcement yet.

DHCP Authorization ( Denied Access )

  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP Authorization ( Denied Access )

    Following Scenerio.
    Root Forest and a child of the forest had an os failure.
    Child domain was unrecoverable. & backup Tapes Failed.
    Removed all references for child domain and waited 10 hours for replication to all DC's through out the enterprise.
    Dcpromo'ed the server back into the forest.
    Now it is correctly functioning ( Almost )
    Disjoined all servers, workstations and rejoined to new domain ( New SIDs )
    I was able to successfully Authorize the DHCP server and it started distributing the scope. 1 hour later the server said ( Hey I dont want to work anymore ) following is the error code:
    Event Type: Error
    Event Source: DhcpServer
    Event Category: None
    Event ID: 1046
    Date: 1/26/2006
    Time: 8:26:39 PM
    User: N/A
    Computer: Server1
    The DHCP/BINL service on the local machine, belonging to the Windows Administrative domain, has determined that it is not authorized to start. It has stopped servicing clients. The following are some possible reasons for this:
    This machine is part of a directory service enterprise and is not authorized in the same domain. (See help on the DHCP Service Management Tool for additional information).

    This machine cannot reach its directory service enterprise and it has encountered an other DHCP service on the network belonging to a directory service enterprise on which the local machine is not authorized.

    *Ok checked the server for Authorization through Netservices node on Sites and services. ( it was there ) Tried to Authorize it again no go didn't work come back later. etc...
    **Next step was to delete the object from the Netservices Node - Deleted and waited for replication.
    ***Tried again to Authorize server still same error code event ID 1046.

    Any one have any Ideas? I seem to have exhausted most that I can think of.
    Many thanks for the help in Advance.

  • #2
    Re: DHCP Authorization ( Denied Access )

    Are you using an account with enterprise admin permissions to Authorize the server??

    I had this a while back when adding a new server to our existing child domain infrastucture. I had to get the correct administrator password for the main domain before i could authorize.


    • #3
      Re: DHCP Authorization ( Denied Access )

      Sorry I should have clarified a little further.
      In the root I setup security permissions for the domain admins of the child domain to write create and modify on the netservices security tab in sites and services node. I tried with the child domain admins rights, and I also tried as root EA account still the same thing. Access denied. There must be an attribute somewhere in the forest that still has references to the old server name. But.
      I disjoined the server from the domain and renamed it rejoined it. uninstall and reinstalled dhcp server service and still same problem access denied.
      I currentl demoted the server to a member server so that I would at least have a DHCP server functioning in the domain. ( Not the best solution, but it works for now .) at least until I can figure out what the problem is when it is in the AD.