Announcement

Collapse
No announcement yet.

Secondary DC Clock refuses to Sync

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Secondary DC Clock refuses to Sync

    Hey,

    I have an 8 seconds difference between my 2 DCs.
    When attempting a w32tm /resync I can see using stripchart that the clock syncs then immediately goes back to an 8 seconds differential again.

    What could possibly be causing this?

    Thanks

  • #2
    Re: Secondary DC Clock refuses to Sync

    Hi,

    Is your PDC syncing to an external NTP (or internal dedicated NTP) ?

    Can you post a "W32tm /monitor" please ?

    Are you in a virtualized env ? If that so, you should disable "Time Syncing with the Host" on the Vm-Agents/Tools -I should say, you must disable-

    Comment


    • #3
      Re: Secondary DC Clock refuses to Sync

      Originally posted by Mazette View Post
      Are you in a virtualized env ? If that so, you should disable "Time Syncing with the Host" on the Vm-Agents/Tools -I should say, you must disable-
      Or better yet, sync the hosts and make sure they're correct.
      Regards,
      Jeremy

      Network Consultant/Engineer
      Baltimore - Washington area and beyond
      www.gma-cpa.com

      Comment


      • #4
        Re: Secondary DC Clock refuses to Sync

        Nop I wont suggest you to do that ; it's not suggested by Microsoft ...


        http://technet.microsoft.com/nl-nl/l...(v=ws.10).aspx

        Use the proper recomandations about Time Syncing.

        Sync your PDC to an external source.
        Then your other DC will sync from the PDC, -by default- .

        Comment


        • #5
          Re: Secondary DC Clock refuses to Sync

          Originally posted by Mazette View Post
          Hi,

          Is your PDC syncing to an external NTP (or internal dedicated NTP) ?

          Can you post a "W32tm /monitor" please ?

          Are you in a virtualized env ? If that so, you should disable "Time Syncing with the Host" on the Vm-Agents/Tools -I should say, you must disable-
          Both servers are indeed virtual (HYPERV 2012 R2) but no agent has been installed.
          However, I did find that reverse dns is somewhat skewed:

          QA-DC.domain.int *** PDC ***[192.168.1.1:123]:
          ICMP: 0ms delay
          NTP: +0.0000000s offset from QA-DC.domain.int
          RefID: 80.84.77.86.rev.sfr.net [86.77.84.80] (WTF???)
          Stratum: 2
          DEV-DC.nayaxvend.int[192.168.1.2:123]:
          ICMP: 0ms delay
          NTP: +9.0584437s offset from QA-DC.domain.int
          RefID: QA-DC.nayaxvend.int [192.168.1.1]
          Stratum: 3

          I will try to fix this and report back.

          Comment


          • #6
            Re: Secondary DC Clock refuses to Sync

            Originally posted by Mazette View Post
            Nop I wont suggest you to do that ; it's not suggested by Microsoft ...


            http://technet.microsoft.com/nl-nl/l...(v=ws.10).aspx

            Use the proper recomandations about Time Syncing.

            Sync your PDC to an external source.
            Then your other DC will sync from the PDC, -by default- .
            Well actually, it seems MS has recently changed this but the recommendation used to be to leave the sync enabled. That was the original recommendation. They then changed per Ben Armstrong's (Microsoft Hyper-V Program Manager) recommendation: http://blogs.msdn.com/b/virtual_pc_g...n-hyper-v.aspx

            But now they are changing it back to recommend disabling the sync: http://technet.microsoft.com/en-us/l...rv(WS.10).aspx

            This guidance has been recently updated to reflect the current recommendation to synchronize time for the guest domain controller from only the domain hierarchy, rather than the previous recommendation to partially disable time synchronization between the host system and guest domain controller.
            Love hitting a moving target.
            Regards,
            Jeremy

            Network Consultant/Engineer
            Baltimore - Washington area and beyond
            www.gma-cpa.com

            Comment


            • #7
              Re: Secondary DC Clock refuses to Sync

              I found the culprit.

              Right click the virtual machines
              Settings
              Integration Services
              Disable Time Synchronization

              gg gl hf lol


              Thank you all!

              Comment


              • #8
                Re: Secondary DC Clock refuses to Sync

                Nice catch !

                For your PDC : RefID: 80.84.77.86.rev.sfr.net [86.77.84.80]
                looks OK for me.
                You can choose another external NTP server as a time source, that you prefer.

                Comment

                Working...
                X