Announcement

Collapse
No announcement yet.

Network Printer - Locally Attached

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Network Printer - Locally Attached

    Hello All,

    I am running a large Kodak Digimaster black and white Printer.

    Our digital operator is getting a new Windows 7 machine, but I cannot seem to get the new machine to properly send to the Digimaster Printer.

    There are currently 3 computers that flawlessly send to the Digimaster printer, 2 MACS and a Windows XP machine. That being said i have also run into the same errors on a seperate windows XP machine, so i do not believe that windows 7 is causing the problem.

    My issues are when I set up the printer, It seems to add correctly, but in the 2 methods I have tried, it has separate issues.

    Add a Printer
    Add a Local Printer
    Create a new Port
    Standard TCP-IP Port - where I enter the IP of my printer - 192.x.x.17

    This is where it says "Additional Port information Required"
    Device Type-
    Standard - Generic Network Card(in a dropdown menu)
    Custom - Settings(this is a button to click)

    Here are my 2 separate methods I have tried that have failed!
    1) I proceeded with the stardard network card option
    i. This option automatically sets it up for RAW Protocol and Port #9100
    b. This brings me to Install the Printer Driver
    c. I click have disk and navigate to my driver and select and click next.
    d. Follow steps to finish
    e. Do not share this printer
    f. Set as default
    g. Finish

    This is where it seems to have installed correctly, but doesn’t function correctly.
    If I send a test print – It errors out – Through the troubleshooter through windows, it comes up with an error “ printer cannot be contacted over the network”

    I am able to ping the printer. I have reinstalled multiple times, used different drivers. I am stuck here. This is where I tried method 2.

    2) I proceeded with the Custom settings at the “Additional port information required” screen.
    a. This is where I had the option to change to LPR Protocol.
    b. This required me to enter a Queue name under LPR Settings – which I named DigitalDell.
    c. This brings me to Install the Printer Driver
    d. I click have disk and navigate to my driver and select and click next.
    e. Follow steps to finish
    f. Do not share this printer
    g. Set as default
    h. Finish

    This is where it seems to have installed correctly again! But doesn’t function correctly again!
    If I send a test print – It seems to send correctly this time.
    Spools in the queue – and then disappears as if it sent correctly.
    However it doesn’t show up on the printer, nor does it print.

    Any and all help would be greatly appreciated!
    Please advise,

    Standard IT

  • #2
    Re: Network Printer - Locally Attached

    There are at least three different printing protocols in common use on TCP/IP networks:
    • The JetDirect protocol (from HP), using TCP port 9100 for a single printer (print servers with multiple printers use 9101 for printer #2, 9102 for #3 and so on)
    • The Line Printer protocol (LPR), which supports multiple printers using different queue names
    • The Internet Printing Protocol (IPP), an HTTP-based protocol using TCP port 631

    As you've seen, the wizard will attempt to create a JetDirect port by default. If your printer doesn't support this protocol, the created printer obviously will not work.

    To determine which of these protocols your printer supports, try opening a connection to the TCP ports in question. You can use the "telnet" client for this (it can be added as a "Feature" on Windows servers). Try these commands in a command line window:
    Code:
    telnet <IP address of your printer> 515
    
    telnet <IP address of your printer> 9100
    
    telnet <IP address of your printer> 631
    If the window goes blank, a service on the printer has replied to the connection request. If the command just hangs with "Connecting To <IP address>...", you can be reasonably certain that the protocol is not supported.
    Originally posted by Standard_IT View Post
    I am able to ping the printer. I have reinstalled multiple times, used different drivers. I am stuck here. This is where I tried method 2.

    2) I proceeded with the Custom settings at the “Additional port information required” screen.
    a. This is where I had the option to change to LPR Protocol.
    b. This required me to enter a Queue name under LPR Settings – which I named DigitalDell.
    You can't just choose a random queue name; you'll have to use the queue name that identifies your printer. Try "lp1" (without the quotes); that usually works.

    Comment


    • #3
      Re: Network Printer - Locally Attached

      Have you checked the port settings on a machine that is working? You should be able to jot down the settings and then configure them on the new computers. You could also get it working on the server and then just share it out from there.
      Regards,
      Jeremy

      Network Consultant/Engineer
      Baltimore - Washington area and beyond
      www.gma-cpa.com

      Comment


      • #4
        Re: Network Printer - Locally Attached

        Thank you Ser Olmy & JeremyW,

        I believe both of you were correct. I had to setup the connection to match the other computers. It was a LPR Connection. My issue was i was trying to switch the TCPIP Port to LPR in the settings. this doesnt work. I had to create a new LPR Port, though it was not listed. Here were my steps to resolve this.


        1) Go to Printers and Devices from start menu
        2) Go to Add Printer
        3) Add a Local Printer
        4) Create New Port
        a. LPR Port – VERY IMPORTANT
        i. Allows Communication with a Unix Based system
        ii. Cannot connect via Standard TCP-IP
        iii. **If LPR Port is not listed as an option.
        1. Go to Control Panel
        2. Go to Programs and Features(Windows 7)
        a. Add or Remove Programs (Windows XP)
        3. On the left pane, select Turn Windows features on of off. (Windows 7)
        a. Add/Remove Windows Components (Windows XP)
        4. (Windows 7)Expand Print and Document Services
        5. (Windows 7)Check all.
        a. Internet Printing Client
        b. LPD Print Service
        c. LPR Port Monitor
        d. Scan Management
        e. Windows Fax and Scan
        6. (Windows XP) Make sure the networking services are checked off.
        a. Networking Services
        b. Other Network File and Print Services
        5) -Enter the Printers IP Address in the field “Name or address of server providing LPD
        6) - Name the Printer in the field “Name of printer or print queue on that server.
        7) - Select the Driver that was previously downloaded from the Kodak website.
        - Finish and Test Print.

        Standard IT

        Comment


        • #5
          Re: Network Printer - Locally Attached

          Thanks for posting your solution.
          Regards,
          Jeremy

          Network Consultant/Engineer
          Baltimore - Washington area and beyond
          www.gma-cpa.com

          Comment

          Working...
          X