Announcement

Collapse
No announcement yet.

AD Site SRV records on DNS don't seem to be refreshing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AD Site SRV records on DNS don't seem to be refreshing

    To carry out one request we recently set up a new site on the AD (Let's call it Site X). Even though there is no local DC at this new site, we had to set it up because we had to deploy a site-specific group policy. With this arrangement the GPO seems to be getting applied correctly on the clients on site but we have an issue with the DC locator service. Initially, in the absence of local DC, we had not set up site-link involving this site, so the local clients were referring to the central datacenter DC's (let's call it Site A) but as it turned out, this default link is not the fastest one. Hence we created a new site-link yesterday between this new site X to another slightly closer site (let's call it Site B -which has many DC's), with a random cost of 200 and replication interval of 60 minutes.

    The problem is that even after 24 hours I can see that the clients on site X are still referring to the datacenter DC's (Site A) where as I would have expected them to talk to Site B DC's when it is now part of an explicit site link? I did a further digging on the DNS SRV records and it looks like the site-specific available-DC-listing (for site X) is still pointing to site A DC's which is what I think is causing the clients to talk to the distant DC's.

    So, I wanted to know what might be going on here. How do I make sure the DNS SRV records for Site X get refreshed with Site B DC's?
    <SPAM LINKS>

    Thanks in advance,
    Last edited by wullieb1; 1st October 2018, 23:24.
Working...
X