Announcement

Collapse
No announcement yet.

missing NTDS Site Settings in ADSI Edit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • missing NTDS Site Settings in ADSI Edit

    Hello,

    Every 15 minutes (yes my replication time is 15 minutes) my eventvwr of all DCs give errors with eventID 1311 and 1550. He's complaining that 1 specific site has no child object NTDS Site settings.

    Indeed, If I look in ADSI Edit in:
    CN=NTDS Settings,CN=DC_Name,CN=Servers,CN=SiteName,CN=Site s,CN=Configuration,DC=LocalDomain,DC=intra
    There is indeed a specific object with class (nTDSSiteSettings) missing, which is present in every other site.
    The name of the missing object is also : "CN=NTDS Site Settings"

    So my question now: How can I fix this?
    Of course, I didn't do anything ( Don't we hear this answer every day? )
    Well at least, I admit, I'm not aware of anything...

    But for a solution...
    An idea is to remove the site , make it again, adapt subnets, site-links, etc... ? I'm not so eager to just 'try' this, my gut feeling says I might cause more problems with this.

    Anyone else have any ideas?

    Thanks you in advance!

    Fred
    Last edited by fredum; 8th November 2010, 16:53.

  • #2
    Re: missing NTDS Site Settings in ADSI Edit

    I'd reckon removing and recreating the site may be a better option than necessarily messin around with adsi
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: missing NTDS Site Settings in ADSI Edit

      Hi,

      Do you have system state backup? Try restoring it from there first, otherwise only way you can recreate ntds settings is rebuild.

      may be others around can also provide second opinion.
      Thanks & Regards
      v-2nas

      MCTS 2008, MCTIP, MCSE 2003, MCSA+Messaging E2K3, MCP, E2K7
      Sr. Wintel Eng. (Investment Bank)
      Independent IT Consultant and Architect
      Blog: http://www.exchadtech.blogspot.com

      Show your appreciation for my help by giving reputation points

      Comment


      • #4
        Re: missing NTDS Site Settings in ADSI Edit

        I'm of the opinion that you should delete the site and recreate it, thereby allowing the KCC to rebuild the inter-site topology.

        Comment


        • #5
          Re: missing NTDS Site Settings in ADSI Edit

          That was indeed my first thought also. I'm gonna try it and let you know how it went.

          Comment


          • #6
            Re: missing NTDS Site Settings in ADSI Edit

            So far we tried 2 things, which didn't help to solve our problem.

            Our initial problem was that we got this error: (This occurs every 15 minutes, Source: NTDS KCC ; Category : Knowledge Consistency Checker; Event 1550)


            The following site has no NTDS Site Settings child object.

            Site:
            CN=Site-"Sitename",CN=Sites,CN=Configuration,DC="localdoma in",DC="internal"

            User Action
            Create an NTDS Site Settings object for this site using Active Directory Sites and Services.

            For this "sitename"-site we first removed the site, and recreated this site again in ADSS.
            This solved the problem of the missing NTDS Site Setting class object which we lost in ADSI.

            But the events remained... (event number 1550)

            After this, we tried to demote the DC, removed the site, waited for replication, re-created the site, and promoted the DC again.

            Also, no resolution.
            The events still popup every 15 minutes.

            Anyone else have any ideas?

            thanks!

            Comment


            • #7
              Re: missing NTDS Site Settings in ADSI Edit

              Solution update.

              The second solution which I wrote was succesfull. (Site removal , DC demote - DC promo - Site creation)

              Off course, this took 2 days to stabilize completely (over 100 DCs). This wasn't solved immediately, but after a few days, all was ok and the events were gone.

              Comment


              • #8
                Re: missing NTDS Site Settings in ADSI Edit

                Good to know it worked for you.
                Thanks & Regards
                v-2nas

                MCTS 2008, MCTIP, MCSE 2003, MCSA+Messaging E2K3, MCP, E2K7
                Sr. Wintel Eng. (Investment Bank)
                Independent IT Consultant and Architect
                Blog: http://www.exchadtech.blogspot.com

                Show your appreciation for my help by giving reputation points

                Comment

                Working...
                X