Announcement

Collapse
No announcement yet.

Having trouble registering new local domain certificate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having trouble registering new local domain certificate

    Hi,

    Not sure this is the correct forum to ask. I hope it is. If not, let me know in which forum should I post this question.

    I have a 2008 R2 domain.
    One of my servers (Visual SVN Server) requires an HTTPS connection via its web interface. The installation is ok, but I receive "Your connection is not secured" error when trying to get to the repository URL via a browser.
    So, I created a new certificate request (from VisualSvn server) and tried to run it with the following "certreq" command using a user with Admin permissions both from the SVN server and from the AD server and received the same error. I also tried to submit the request file from the MMC - Certification Authority as well but received the same error.

    The command I used: "certreq -submit -attrib "CertificateTemplate: WebServer" visualsvn.req visualsvn.cer"

    The Error I received: "Error Parsing Request A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file. 0x800b0101 (-2146762495)"

    I can also see that my AD server itself has an expired certificate and when I try to renew it (either with the same Key or with a new Key) I receive an error that the Domain Controller Authentication status is unavailable because the permissions to this certification authority do not allow the current user to enroll for certificates, and that a valid CA configured to issue certificates based on this template cannot be located, or the CA does not support this operation, or the CA is not trusted.

    I would really appreciate your help with this issue.

    Thanks,
    Michael



  • #2
    Found The Solution here:
    https://social.technet.microsoft.com...m=winservergen

    Comment

    Working...
    X