No announcement yet.

adprep rodcprep Issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • adprep rodcprep Issue


    I have recently upgraded my domain to accomodate Windows Server 2008 R2 domain controllers. These are my vitals:

    Forest Functional level: Windows Server 2003
    Domain Functional level: Windows Server 2003

    I have successfully run:

    adprep /forestprep
    adprep /domainprep

    I am having issues with the /rodcprep part however. When i run it i get this:

    D:\support\adprep>adprep /rodcprep
    Adprep connected to the domain FSMO:

    Adprep detected the operation on partition DC=mydomain,DC=com has been performed.
    Skipping to next partition.
    ================================================== ============================

    Adprep detected the operation on partition DC=DomainDnsZones,DC=mydomain,DC=com ha
    s been performed. Skipping to next partition.
    ================================================== ============================

    ================================================== ============================
    Adprep found partition DC=ForestDnsZones,DC=mydomain,DC=com, and is about to updat
    e the permissions.

    Adprep could not contact a replica for partition DC=ForestDnsZones,DC=mydomain,DC=

    Adprep encountered an LDAP error.
    Error code: 0x0. Server extended error code: 0x0, Server error message: (null).

    Adprep failed the operation on partition DC=ForestDnsZones,DC=mydomain,DC=com. Ski
    pping to next partition.
    ================================================== ============================

    Adprep completed with errors. Not all partitions are updated. See the ADPrep.log
    in the C:\Windows\debug\adprep\logs\20100513151326 directory for more informati

    To successfully update all partititions, the current logged on user needs to be
    a member of Enterprise Admins group. If that is not the case, please correct th
    e problem, and then restart Adprep.

    I have followed the MS KB article below and checked the fSMORoleOwner attribute in ADSI Edit and this is a valid domain controller which is up and running and contactable

    My concern is this line:

    Adprep could not contact a replica for partition DC=ForestDnsZones,DC=mydomain,DC=com.

    What is a/the replica it refers to?
    Is this another DC within the site or within the domain?

    Any help would be appreciated


  • #2
    Re: adprep rodcprep Issue

    I'm an idiot.

    The context of the VB script supplied by the MS article needs to changed to update the other partitions.

    i.e. this will update the DomainDnsZones:

    cscript fixfsmo.vbs DC=DomainDnsZones,DC=contoso,DC=com

    and this will update the ForestDnsZones:

    cscript fixfsmo.vbs DC=ForestDnsZones,DC=contoso,DC=com


    After i ran that the /rodcprep process completed without error



    • #3
      Re: adprep rodcprep Issue

      Good catch!
      Tom Jones
      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
      PhD, MSc, FIAP, MIITT
      IT Trainer / Consultant
      Ossian Ltd

      ** Remember to give credit where credit is due and leave reputation points where appropriate **