Announcement

Collapse
No announcement yet.

AD Home Folders Not Mapping

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AD Home Folders Not Mapping

    I am running 3 MS Server 2003 R2 SP2 64bit and 2 MS Server 2003 R2 SP2 32bit servers in an AD environment.

    I have created an OU off of my domain called "Maple" under that OU I have individual OU's representing each department ie: "Dept". Under each department OU are the individual users for that department. I created the users and their HOME folder connected on H: to \\FileServer\F$\Dept\User

    When I setup a client PC and logon as admin (my account) with Membership that of, Administrators, Domain Admins, Domain Users, and Dept - my Home folder will be mapped no problem.

    When I sign on as a regular user with Membership that of, Domain Users, and Users, No drives are mapped.

  • #2
    Re: AD Home Folders Not Mapping

    Admin shares (F$) are only available to local admins, not to regular users
    Try sharing Dept (maybe as Dept$ if you dont want it seen) and map the drive to \\FileServer\Dept$\User
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: AD Home Folders Not Mapping

      Thanks, that worked!

      Comment


      • #4
        Re: AD Home Folders Not Mapping

        I have a new issues, where some of my users map their home folders and other dont. All of my users run pretty much the same logon script along with a H: connection to their home folders. I thought it was a policy problem so I enabled the wait for network policy and still no luck....

        any help is greatly appreciated.

        Comment


        • #5
          Re: AD Home Folders Not Mapping

          Use RSoP and gpresult to check the policies are being applied to the users on their own computers.
          Is there any pattern to the problem?
          What client OS are the users on?
          Can you post the login script?
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment


          • #6
            Re: AD Home Folders Not Mapping

            I ran RSoP they are getting the policy. I have not noticed any patterns... Clients are running XP Pro SP3
            here is the logon script they are running along with home folders mapped to
            H: \\fileserv\f$\DEPT700\SC700


            @echo off

            copy \\fileserv\public\ncshtdwn.exe c:\ncshtdwn.exe
            at /delete /yes
            at 19:30 /interactive c:\ncshtdwn.exe /2

            net use s: \\fileserv\dept700
            net use g: \\gbaserv\gba
            net use k: \\fileserv\DEPT700\shared


            FYI - I have also tried adding NET USE * /DELETE /Y
            Last edited by bpauljr; 27th August 2010, 13:34.

            Comment


            • #7
              Re: AD Home Folders Not Mapping

              try adding:
              net use h: /home
              to the script
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                Re: AD Home Folders Not Mapping

                when I added that line its stopping the script asking, Enter user name for 'fileserv'
                I added the users name and pass and got, Logon failure: unknown user name or bad password. - I tried a few times.

                Comment


                • #9
                  Re: AD Home Folders Not Mapping

                  Sorry, read your post again
                  You should NOT use the administrative shares (e.g. f$) in a home directory path as the user would need to be an administrator on the server to access them.

                  Instead, on filesrv, share F:\DEPT700\SC700 as e.g. "HomeDirs" (or HomeDirs$ if you want it hidden), then in ADUC set the home directory as \\filesrv\HomeDirs\%username%
                  Tom Jones
                  MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                  PhD, MSc, FIAP, MIITT
                  IT Trainer / Consultant
                  Ossian Ltd
                  Scotland

                  ** Remember to give credit where credit is due and leave reputation points where appropriate **

                  Comment


                  • #10
                    Re: AD Home Folders Not Mapping

                    I took out the F$ and ran the logon script again with the included

                    net use h: /home

                    and it worked!!!

                    Here is my working script...

                    @echo off

                    copy \\fileserv\public\ncshtdwn.exe c:\ncshtdwn.exe
                    at /delete /yes
                    at 19:30 /interactive c:\ncshtdwn.exe /2

                    net use h: /home
                    net use s: \\fileserv\dept700
                    net use g: \\gbaserv\gba
                    net use k: \\fileserv\DEPT700\shared


                    I am not sure where are you asking i should add the
                    \\filesrv\HomeDirs\%username%

                    Do I need to add the h: /home for all my users logon scripts?

                    Comment


                    • #11
                      Re: AD Home Folders Not Mapping

                      If it is working, dont change it!

                      As I read your post #6, you have set the home directories in Active Directory Users and Computers (ADUC) to refer to the f$ administrative share. If you have, you need to change that to a normal share, which I suggested could be called HomeDirs

                      Once you have defined the home directory in ADUC you have two options:
                      1) Define a drive letter in ADUC (in which case it should map without a script
                      or
                      2) use the net use h: / home (where h can be any free drive letter) which will pick up the path in ADUC.
                      Tom Jones
                      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                      PhD, MSc, FIAP, MIITT
                      IT Trainer / Consultant
                      Ossian Ltd
                      Scotland

                      ** Remember to give credit where credit is due and leave reputation points where appropriate **

                      Comment


                      • #12
                        Re: AD Home Folders Not Mapping

                        Originally posted by bpauljr View Post

                        Here is my working script...

                        @echo off

                        copy \\fileserv\public\ncshtdwn.exe c:\ncshtdwn.exe
                        at /delete /yes
                        at 19:30 /interactive c:\ncshtdwn.exe /2

                        <...>
                        Are the users local administrators?
                        The user logon script copies a file to the root of the systemdrive, regular users can't do that. And the script start AT.exe, regular users can't do that eighter.
                        The commands on the three lines should be done with a computer startup script.

                        \Rems
                        Last edited by Rems; 28th August 2010, 02:43.

                        This posting is provided "AS IS" with no warranties, and confers no rights.

                        __________________

                        ** Remember to give credit where credit's due **
                        and leave Reputation Points for meaningful posts

                        Comment

                        Working...
                        X