Announcement

Collapse
No announcement yet.

Sysvolv & netlogon not shared

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sysvolv & netlogon not shared

    Two Win2k3 servers, 64 bit.

    Both are DC's but one of my DC's Sysvol isn't shared and DCDiag /test:netlogons fails.

    How can I get this DC corrected?


    C:\>dcdiag /test:netlogons
    Domain Controller Diagnosis
    Performing initial setup:
    Done gathering initial info.
    Doing initial required tests
    Testing server: Default-First-Site-Name\BMP-AD1
    Starting test: Connectivity
    ......................... BMP-AD1 passed test Connectivity
    Doing primary tests
    Testing server: Default-First-Site-Name\BMP-AD1
    Starting test: NetLogons
    Unable to connect to the NETLOGON share! (\\BMP-AD1\netlogon)
    [BMP-AD1] An net use or LsaPolicy operation failed with error 1203, No
    network provider accepted the given network path..
    ......................... BMP-AD1 failed test NetLogons
    Running partition tests on : DomainDnsZones
    Running partition tests on : ForestDnsZones
    Running partition tests on : Schema
    Running partition tests on : Configuration
    Running partition tests on : metrohmusa
    Running enterprise tests on : metrohmusa.com
    C:\>

  • #2
    Re: Sysvolv & netlogon not shared

    The easiest way would probably be to demote it and repromote it using DCPROMO.

    Comment


    • #3
      Re: Sysvolv & netlogon not shared

      Originally posted by joeqwerty View Post
      The easiest way would probably be to demote it and repromote it using DCPROMO.

      so I don't have to re-install?

      Comment


      • #4
        Re: Sysvolv & netlogon not shared

        No. On the server with the problem, when you run DCPROMO to demote it, it will remove all of the AD components. The server will then be a normal member server. You can then run DCPROMO again to make it a DC and see if that fixes the problem. Wait about 30 to 60 minutes between the demotion and promotion.

        Comment


        • #5
          Re: Sysvolv & netlogon not shared

          ok, I dcpromo'd it and made it a regular server after reboot. Waited 45 minutes and ran dcrpomo once again. Re-booted and I still have the same problem.

          Comment


          • #6
            Re: Sysvolv & netlogon not shared

            How is DNS configured on this server?
            Does DNS have the correct A record in DNS for this server?
            Does DNS have SRV records for this server in DNS?
            Are you able to browse the network from this server?
            Do you see this server in the network from another machine?
            Is the Windows Firewall enabled on this server?
            Is there a third party firewall on this server?

            Comment


            • #7
              Re: Sysvolv & netlogon not shared

              Originally posted by joeqwerty View Post
              How is DNS configured on this server?
              Does DNS have the correct A record in DNS for this server?
              Does DNS have SRV records for this server in DNS?
              Are you able to browse the network from this server?
              Do you see this server in the network from another machine?
              Is the Windows Firewall enabled on this server?
              Is there a third party firewall on this server?

              I do have an A record for this server.
              what's SRV?
              I can browse my entire network from the server.
              I can see my server from my laptop on the network.
              no 3rd party firewalls
              firewall is off.

              I just re-installed the entire OS, added all the ms updates and then ran dcrpomo, enter the dns info again and still the same error as this morning.


              C:\>dcdiag /test:netlogons
              Domain Controller Diagnosis
              Performing initial setup:
              Done gathering initial info.
              Doing initial required tests
              Testing server: Default-First-Site-Name\BMP-AD1
              Starting test: Connectivity
              ......................... BMP-AD1 passed test Connectivity
              Doing primary tests
              Testing server: Default-First-Site-Name\BMP-AD1
              Starting test: NetLogons
              Unable to connect to the NETLOGON share! (\\BMP-AD1\netlogon)
              [BMP-AD1] An net use or LsaPolicy operation failed with error 1203, No
              network provider accepted the given network path..
              ......................... BMP-AD1 failed test NetLogons
              Running partition tests on : DomainDnsZones
              Running partition tests on : ForestDnsZones
              Running partition tests on : Schema
              Running partition tests on : Configuration
              Running partition tests on : metrohmusa
              Running enterprise tests on : metrohmusa.com
              C:\>

              Comment


              • #8
                Re: Sysvolv & netlogon not shared

                From the first DC, type this at the run box: \\second_dc, where second_dc is the name of the second DC. Do you see a NETLOGON folder? Do you see a SYSVOL folder?

                Is NetBIOS over TCP/IP enabled on the NIC of the second DC?
                Is File & Printer sharing enabled on the NIC of the second DC?
                Is the second DC using itself for it's primary DNS and the first DC as it's secondary DNS?

                Comment


                • #9
                  Re: Sysvolv & netlogon not shared

                  also ran the netdiag /fix:


                  C:\>Netdiag /Fix
                  ..................................
                  Computer Name: BMP-AD1
                  DNS Host Name: bmp-ad1.metrohmusa.com
                  System info : Microsoft Windows Server 2003 (Build 3790)
                  Processor : EM64T Family 6 Model 23 Stepping 6, GenuineIntel
                  List of installed hotfixes :
                  KB923561
                  KB924667-v2
                  KB925398_WMP64
                  KB925902
                  KB926122
                  KB927891
                  KB929123
                  KB930178
                  KB932168
                  KB936357
                  KB938127
                  KB938464-v2
                  KB941569
                  KB943055
                  KB943460
                  KB944338-v2
                  KB944653
                  KB945553
                  KB946026
                  KB948496
                  KB950762
                  KB950974
                  KB951066
                  KB951748
                  KB952004
                  KB952069
                  KB952954
                  KB954600
                  KB955069
                  KB956572
                  KB956802
                  KB956803
                  KB957097
                  KB958469
                  KB958644
                  KB958687
                  KB959426
                  KB960225
                  KB960803
                  KB960859
                  KB961371-v2
                  KB961501
                  KB967715
                  KB968389
                  KB968537
                  KB970238
                  KB970653-v3
                  KB971032
                  KB971557
                  KB971633
                  KB971657
                  KB972260
                  KB973346
                  KB973354
                  KB973507
                  KB973540
                  KB973815
                  KB973869
                  Q147222

                  Netcard queries test . . . . . . . : Passed

                  Per interface results:
                  Adapter : Local Area Connection
                  Netcard queries test . . . : Passed
                  Host Name. . . . . . . . . : bmp-ad1
                  IP Address . . . . . . . . : 192.168.100.4
                  Subnet Mask. . . . . . . . : 255.255.255.0
                  Default Gateway. . . . . . : 192.168.100.1
                  Dns Servers. . . . . . . . : 192.168.100.3

                  AutoConfiguration results. . . . . . : Passed
                  Default gateway test . . . : Passed
                  NetBT name test. . . . . . : Passed
                  [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
                  r Service', <20> 'WINS' names is missing.
                  WINS service test. . . . . : Skipped
                  There are no WINS servers configured for this interface.

                  Global results:

                  Domain membership test . . . . . . : Failed
                  [WARNING] Ths system volume has not been completely replicated to the local
                  machine. This machine is not working properly as a DC.

                  NetBT transports test. . . . . . . : Passed
                  List of NetBt transports currently configured:
                  NetBT_Tcpip_{703DC481-37B8-4EAE-B6D5-F64180F01B8C}
                  1 NetBt transport currently configured.

                  Autonet address test . . . . . . . : Passed

                  IP loopback ping test. . . . . . . : Passed

                  Default gateway test . . . . . . . : Passed

                  NetBT name test. . . . . . . . . . : Passed
                  [WARNING] You don't have a single interface with the <00> 'WorkStation Servi
                  ce', <03> 'Messenger Service', <20> 'WINS' names defined.

                  Winsock test . . . . . . . . . . . : Passed

                  DNS test . . . . . . . . . . . . . : Passed
                  PASS - All the DNS entries for DC are registered on DNS server '192.168.100.
                  3' and other DCs also have some of the names registered.

                  Redir and Browser test . . . . . . : Passed
                  List of NetBt transports currently bound to the Redir
                  NetBT_Tcpip_{703DC481-37B8-4EAE-B6D5-F64180F01B8C}
                  The redir is bound to 1 NetBt transport.
                  List of NetBt transports currently bound to the browser
                  NetBT_Tcpip_{703DC481-37B8-4EAE-B6D5-F64180F01B8C}
                  The browser is bound to 1 NetBt transport.

                  DC discovery test. . . . . . . . . : Passed

                  DC list test . . . . . . . . . . . : Passed

                  Trust relationship test. . . . . . : Passed
                  Secure channel for domain 'METROHMUSA' is to '\\bmp-ad2.metrohmusa.com'.

                  Kerberos test. . . . . . . . . . . : Passed

                  LDAP test. . . . . . . . . . . . . : Passed

                  Bindings test. . . . . . . . . . . : Passed

                  WAN configuration test . . . . . . : Skipped
                  No active remote access connections.

                  Modem diagnostics test . . . . . . : Passed
                  IP Security test . . . . . . . . . : Skipped
                  Note: run "netsh ipsec dynamic show /?" for more detailed information

                  The command completed successfully
                  C:\>

                  Comment


                  • #10
                    Re: Sysvolv &amp; netlogon not shared

                    Are the Workstation and Server services running on the server?

                    Comment


                    • #11
                      Re: Sysvolv &amp; netlogon not shared

                      Originally posted by joeqwerty View Post
                      Are the Workstation and Server services running on the server?

                      yes they are running...

                      Comment


                      • #12
                        Re: Sysvolv &amp; netlogon not shared

                        What about my previous post, the one before your netdiag post?

                        Comment


                        • #13
                          Re: Sysvolv &amp; netlogon not shared

                          Originally posted by joeqwerty View Post
                          From the first DC, type this at the run box: \\second_dc, where second_dc is the name of the second DC. Do you see a NETLOGON folder? Do you see a SYSVOL folder?

                          Is NetBIOS over TCP/IP enabled on the NIC of the second DC?
                          Is File & Printer sharing enabled on the NIC of the second DC?
                          Is the second DC using itself for it's primary DNS and the first DC as it's secondary DNS?

                          sorry didn't see this post:

                          netbios is now enabled on the second DC (the working one)
                          F&P are already enabled
                          2nd dc is primary dns and bad dc is secondary dns.

                          yes I can view the sysvol and netlog from the first DC (bad one). I also ran it from the second DC but no sysvol or netlog folders
                          Last edited by bigalusn; 27th August 2009, 19:09.

                          Comment


                          • #14
                            Re: Sysvolv &amp; netlogon not shared

                            Re-installed once again, still same problem. Might have to call Micro$oft.

                            Comment


                            • #15
                              Re: Sysvolv &amp; netlogon not shared

                              Maybe someone else here will chime in with some advice.

                              Comment

                              Working...
                              X