Announcement

Collapse
No announcement yet.

Not User Option to Active Directory Users and Computers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not User Option to Active Directory Users and Computers

    Hello,

    I want add unlock user option to active directory users and computers.
    In the knowledge base, there is an article : "Add Unlock User Option to Active Directory Users and Computers" http://www.petri.co.il/add_unlock_user_option_to_dsa.htm
    I followed instructions, but there is not option "Unlock User" in the context menu when i want unlock a user account. I just customized the domain name.
    I have an AD 2003 with one domain controller simply.

    Here is parameter that I have change in Adsiedi
    Click image for larger version

Name:	pict1.JPG
Views:	2
Size:	22.8 KB
ID:	468339

    Can you help me ?
    Thank you.
    Last edited by ceddes; 15th August 2009, 07:06.

  • #2
    Re: Not User Option to Active Directory Users and Computers

    It appears you are using the name of a server -- or else you have hidden it too well
    It should be the domain name in the format \\domain.local (or whatever you use)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Not User Option to Active Directory Users and Computers

      I tried with name server, domain name and a local path (c:\windows\system32\unlock_user.vbs), but result is the same.

      My server is 2003R2 SP2 and my computer XP PRO SP3.
      Option is not displayed to Active Directory Users and Computers.

      Is there another means to add this option ?
      Perhaps in a automatic way !

      Comment


      • #4
        Re: Not User Option to Active Directory Users and Computers

        No automatic option -- sorry!
        When I did it (successfully) I
        1) Created script (copy/paste) -- made sure i saved it as a VBS
        2) Saved in NETLOGON share on a DC (therefore replicated automatically to all DCs)
        3) Checked it was visible in \\domain.local\netlogon (obviously used correct domain name!)
        4) Opened ADSIEdit, connected to "well known naming context / configuration" and navigated to same path as shown in article
        5) Edited adminContextMenu using \\domain.local\netlogon\scriptname.vbs type format

        Worked perfectly from all DCs after replication
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Not User Option to Active Directory Users and Computers

          I followed your instructions.
          Here is a capture of screen :
          Click image for larger version

Name:	Sans titre.JPG
Views:	1
Size:	22.9 KB
ID:	464194

          I changed the computer name by the domain name.
          I tried with an ip address or with a computer name, but the problem is the same.
          There is not replication, because there is just one domain controller.
          My domain AD works correctly and i have not problem with it.

          Instructions are simple, but option is not displayed to Active Directory Users and Computers.
          I have a problem perhaps elsewhere !

          what can i do else ?
          Thank you.

          Comment

          Working...
          X